<!doctype html><html lang=en-US class=gnt__njs data-u-s=anon><head><meta charset=utf-8 /><meta name=viewport content="width=device-width,initial-scale=1,minimum-scale=1"/><meta name=theme-color content=#0098FE /><title>Greencastle man's book encompasses daughter's addiction, death, legacy</title><meta property=og:title content="A daughter's overdose death leads to 'The CALLing'"/><link rel=amphtml href=https://amp.echo-pilot.com/amp/8090203002 /><meta property=article:author content="Shawn Hardy"/><meta property=article:content_tier content=free /><meta property=article:opinion content=false /><link rel=dns-prefetch href=//user.echo-pilot.com /><link rel=preconnect href=https://user.echo-pilot.com /><link rel=dns-prefetch href=//www.gannett-cdn.com /><link rel=dns-prefetch href=//securepubads.g.doubleclick.net /><link rel=preconnect href=https://securepubads.g.doubleclick.net /><link rel=dns-prefetch href=//adservice.google.com /><link rel=preconnect href=https://adservice.google.com /><link rel=dns-prefetch href=//tpc.googlesyndication.com /><link rel=preconnect href=https://tpc.googlesyndication.com /><link rel=dns-prefetch href=//googleads.g.doubleclick.net /><link rel=dns-prefetch href=//s0.2mdn.net /><link rel=dns-prefetch href=//partner.googleadservices.com /><link rel=dns-prefetch href=//www.googletagservices.com /><link rel=preconnect href=https://www.googletagservices.com /><link rel=dns-prefetch href=//static.adsafeprotected.com /><link rel=preconnect href=https://static.adsafeprotected.com /><link rel=dns-prefetch href=//pixel.adsafeprotected.com /><link rel=preconnect href=https://pixel.adsafeprotected.com crossorigin/><link rel=dns-prefetch href=//c.amazon-adsystem.com /><link rel=preconnect href=//c.amazon-adsystem.com /><link rel=dns-prefetch href=//js-sec.indexww.com /><link rel=preconnect href=https://js-sec.indexww.com /><link rel=dns-prefetch href=//aax.amazon-adsystem.com /><link rel=preconnect href=//aax.amazon-adsystem.com /><link rel=dns-prefetch href=//fastlane.rubiconproject.com /><link rel=preconnect href=https://fastlane.rubiconproject.com /><link rel=dns-prefetch href=//bidder.criteo.com /><link rel=preconnect href=https://bidder.criteo.com /><link rel=dns-prefetch href=//colossusssp.com /><link rel=preconnect href=https://colossusssp.com /><link rel=dns-prefetch href=//gannett-d.openx.net /><link rel=preconnect href=https://gannett-d.openx.net /><link rel=dns-prefetch href=//hbopenbid.pubmatic.com /><link rel=preconnect href=https://hbopenbid.pubmatic.com /><link rel=dns-prefetch href=//ads.pubmatic.com /><link rel=dns-prefetch href=//as-sec.casalemedia.com /><link rel=preconnect href=https://as-sec.casalemedia.com /><link rel=dns-prefetch href=//ib.adnxs.com /><link rel=preconnect href=https://ib.adnxs.com /><link rel=dns-prefetch href=//adserver.adtechus.com /><link rel=preconnect href=https://adserver.adtechus.com /><link rel=dns-prefetch href=//apex.go.sonobi.com /><link rel=preconnect href=https://apex.go.sonobi.com /><link rel=dns-prefetch href=//sofia.trustx.org /><link rel=preconnect href=https://sofia.trustx.org /><link rel=dns-prefetch href=//tlx.3lift.com /><link rel=preconnect href=https://tlx.3lift.com /><link rel=dns-prefetch href=//e.serverbid.com /><link rel=preconnect href=https://e.serverbid.com /><link rel=dns-prefetch href=//confiant-integrations.global.ssl.fastly.net /><link rel=preconnect href=https://confiant-integrations.global.ssl.fastly.net /><link rel=preconnect href=https://s0.2mdn.net /><link rel=preconnect href=https://ads.adaptv.advertising.com /><link rel=preconnect href=https://search.spotxchange.com /><link rel=preconnect href=https://static.adsafeprotected.com /><link rel=preconnect href=https://imasdk.googleapis.com /><link rel=dns-prefetch href=//ads.adaptv.advertising.com /><link rel=dns-prefetch href=//search.spotxchange.com /><link rel=dns-prefetch href=//static.adsafeprotected.com /><link rel=dns-prefetch href=//imasdk.googleapis.com /><link rel=dns-prefetch href=//a.teads.com /><link rel=dns-prefetch href=//a.teads.tv /><link rel=preconnect href=https://a.teads.tv /><link rel=dns-prefetch href=//geolocation.onetrust.com /><link rel=preconnect href=https://geolocation.onetrust.com /><link rel=dns-prefetch href=//atoms.echo-pilot.com /><link rel=dns-prefetch href=//cdn.taboola.com /><link rel=preconnect href=https://cdn.taboola.com /><link rel=dns-prefetch href=//trc.taboola.com /><link rel=preconnect href=https://trc.taboola.com /><link rel=dns-prefetch href=//www.usatodaynetworkservice.com /><link rel=preload as=fetch type=application/json href=https://user.echo-pilot.com/NECP-GUP/user/ crossorigin=use-credentials /><link rel=preload as=script href=/tangstatic/js/pbjsandwich-q1a2z36b1cc949.min.js /><link rel=preload as=script href=https://c.amazon-adsystem.com/aax2/apstag.js /><link rel=preload as=script href=https://js-sec.indexww.com/ht/p/184808-89514051626416.js /><link rel=preload as=script href=https://static.adsafeprotected.com/iasPET.1.js /><link rel=preload as=script href=https://securepubads.g.doubleclick.net/tag/js/gpt.js /><link rel=preload as=script href=https://confiant-integrations.global.ssl.fastly.net/r5TdgVvkbv-PeaJCKaQfCh5Xsto/gpt_and_prebid_v3l/config.js /><link rel=preload as=script href=/tangstatic/js/main-q1a2z31304cff7.min.js /><link rel=preload as=script href=https://geolocation.onetrust.com/cookieconsentpub/v1/geo/location/gnt.otgc /><link rel=preload as=script href=https://cdn.taboola.com/libtrc/gannett-network/loader.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/controls-a427b147.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/share-4cfe2242.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/tealplayer-ac0dc3b6.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-comscore-f1701de9.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-gcianalytics-23c0960c.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-hls-aa645eb8.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-parsely-9e946b2b.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/encore-04455b51.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/teal-ima-ac4c537c.min.js /><link rel=preload as=fetch href="https://hlsmedia.gannett-cdn.com/authoring/video-renditions/94a7eea1-c25c-4ee1-9463-1c193b5d615f/9247d843-38e3-4d37-902b-cfd76d17fa3d/1080p_30fps,720p_30fps,480p_30fps,master.m3u8?subtitles=4899064001" crossorigin/><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/hls/hls.0.14.9.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/comscore/streamsense-5.1.1.160316.min.js /><link rel=preload as=script href=/gannett-web/apps/teal/dist/vendor/ias/ias-3.5.1.min.js /><link rel=preload as=script href=https://s0.2mdn.net/instream/video/client.js /><link rel=preload as=script href=https://imasdk.googleapis.com/js/sdkloader/ima3.js /><meta name=description content="&#34;The CALLing&#34; by Mike Straley is about his daughter Leah, her struggle with addiction, her death and how he and his wife Robin help women in recovery."/><meta property=og:description content="&#34;The CALLing&#34; by Mike Straley is about his daughter Leah, her struggle with addiction, her death and how he and his wife Robin help women in recovery."/><meta property=fb:pages content=1549238078423724 /><meta property=fb:app_id content=281271339617085 /><link rel=canonical href=https://www.echo-pilot.com/story/news/2021/07/26/greencastle-mans-book-encompasses-daughters-addiction-death-legacy-opioids-fentanyl-leah-straley/8090203002/ /><meta property=og:url content=https://www.echo-pilot.com/story/news/2021/07/26/greencastle-mans-book-encompasses-daughters-addiction-death-legacy-opioids-fentanyl-leah-straley/8090203002/ /><meta property=og:site_name content="Echo Pilot"/><meta property=og:image content="https://www.gannett-cdn.com/presto/2021/07/26/NECP/ce91506f-1997-4dcd-b451-1eebcb4eef1d-mike_straley_signing_book.jpg?crop=5759,3240,x0,y292&width=3200&height=1801&format=pjpg&auto=webp"/><meta property=og:image:width content=3200 /><meta property=og:image:height content=1801 /><meta name=ROBOTS content="NOODP, NOYDIR, max-image-preview:large"/><meta name=google content=notranslate /><meta property=og:type content=article /><script>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</script><style>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</style><meta name=twitter:card content=summary_large_image /><meta name=twitter:image content="https://www.gannett-cdn.com/presto/2021/07/26/NECP/ce91506f-1997-4dcd-b451-1eebcb4eef1d-mike_straley_signing_book.jpg?crop=5759,3240,x0,y292&width=1600&height=800&format=pjpg&auto=webp"/><meta name=twitter:site content=@ /><meta name=twitter:creator content=@ /><meta name=twitter:title content="A daughter's overdose death leads to 'The CALLing'"/><meta name=twitter:description content="&#34;The CALLing&#34; by Mike Straley is about his daughter Leah, her struggle with addiction, her death and how he and his wife Robin help women in recovery."/></head><body><svg style=display:none><symbol id=gnt_svg_external viewBox="0 0 18 18"><path d="M12.43 5.5H10.5V4H15v4.5h-1.5V6.55l-4.56 4.56-1.06-1.06 4.55-4.55zm1.07 9v-3.75H15V16H3V4h5.25v1.5H4.5v9h9z"/></symbol><svg id=gnt_svg_share_facebook viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#4460a0)><path d="M10.5932 20.9998C6.291 20.3204 3 16.5743 3 12.055 3 7.054 7.0294 3 12 3s9 4.054 9 9.0549c0 4.5198-3.2914 8.266-7.5943 8.9451v-6.3188h2.097l.3991-2.6175h-2.496v-1.6985c0-.716.3486-1.414 1.4666-1.414h1.1349V6.7227s-1.03-.1769-2.0146-.1769c-2.0558 0-3.3995 1.2536-3.3995 3.523v1.9948H8.3081v2.6175h2.2851v6.3186z"/></svg><symbol id=gnt_svg_share_twitter viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#00aaec)><path d="M21 6.776a7.213 7.213 0 0 1-2.12.596 3.778 3.778 0 0 0 1.623-2.095 7.273 7.273 0 0 1-2.346.918A3.642 3.642 0 0 0 15.462 5c-2.038 0-3.692 1.696-3.692 3.787 0 .296.032.585.095.862-3.069-.158-5.79-1.664-7.612-3.958a3.856 3.856 0 0 0-.5 1.906c0 1.313.652 2.472 1.643 3.152a3.626 3.626 0 0 1-1.673-.473v.047c0 1.835 1.273 3.366 2.963 3.713-.31.089-.636.133-.973.133-.238 0-.47-.023-.695-.067.47 1.504 1.833 2.599 3.45 2.628A7.292 7.292 0 0 1 3 18.3 10.282 10.282 0 0 0 8.66 20c6.794 0 10.508-5.77 10.508-10.774 0-.164-.003-.329-.01-.49A7.58 7.58 0 0 0 21 6.776"/></symbol><symbol id=gnt_svg_share_email viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#626262)><path d="M3 5.88c0-.49.4-.88.9-.88h16.2c.5 0 .9.4.9.88v12.24c0 .49-.4.88-.9.88H3.9a.9.9 0 0 1-.9-.88V5.88zm9 5.21L3 6.74v1.74l9 4.35 9-4.35V6.74l-9 4.35z"/></symbol><symbol id=gnt_svg_shareapi viewBox="0 0 24 24" style=fill:var(--gnt-sfc,#000)><path d="M14 5l6 7-6 7V5zm0 4v6c-1.937-.271-3.937.062-6 1s-3.73 2.271-5 4c.909-3.576 2.242-6.242 4-8s4.091-2.758 7-3z"/></symbol><symbol id=gnt_svg_video_play viewBox="0 0 84 84"><circle stroke=#0098FE stroke-width=4 fill=#303030 cx=40.5 cy=40.5 r=38 /><path fill=#FFF d="M56 40.23l-22.5 13.5v-27z"/></symbol></svg><header class=gnt_n onmousedown=event.stopPropagation() onmouseup=event.stopPropagation()><div class=gnt_n_lg_w><button class=gnt_n_sb data-g-r=base_sb data-t-l=":n|v|c|skip to main content" aria-label="Skip to main content"></button><a class=gnt_n_lg href=/ aria-label="Echo Pilot" data-t-l=:n|v|c|logo><svg id=gnt_svg_lg fill=#303030 class=gnt_n_lg_svg preserveAspectRatio="xMinYMid meet" viewBox="0 0 285.64 48.47"><path d="M81.36 25.6c.96-1.8 1.99-3.47 3.36-4.92a10.75 10.75 0 019.64-3.5c3.43.43 5.83 2.78 6.36 6.33.15 1.04.23 2.1.23 3.15.02 5.18.01 10.35.01 15.53 0 3.04.63 3.73 3.7 4.05.23.02.45.07.78.12l.06 1.24H89.17l-.06-1.22 1.79-.28c1.83-.3 2.6-.96 2.62-2.76.06-6.43.03-12.86.02-19.29 0-.2-.06-.39-.08-.59-.3-2.78-2.58-3.49-4.56-3.15a6.9 6.9 0 00-3.46 1.81 13.96 13.96 0 00-3.55 5.17 5.4 5.4 0 00-.37 1.91c-.03 4.29-.02 8.57-.02 12.86 0 3.23.54 3.82 3.77 4.17l.57.1v1.28H69.67v-1.26c.65-.1 1.3-.18 1.94-.29 1.6-.28 2.3-1.06 2.39-2.66.03-.49.03-.99.03-1.48V6.01c0-.49 0-.99-.03-1.48-.09-1.46-.76-2.32-2.19-2.69-.76-.2-1.55-.28-2.33-.41l-1.11-.17V-.01h13.26l-.27 25.61zm-46.92-7.21h-1.47c-.26-1.34-.46-2.67-.79-3.97-.4-1.56-.79-3.14-1.39-4.62a7.13 7.13 0 00-5.88-4.58c-3.8-.54-7.63-.16-11.53-.14v17.69c.03.02.07.11.12.11 2.5-.04 5.02.09 7.5-.17 2.77-.28 4.01-1.68 4.54-4.44.17-.9.36-1.8.55-2.74h1.5v16.62l-1.44.1c-.14-.57-.27-1.06-.38-1.57-.15-.64-.26-1.29-.42-1.93a4.65 4.65 0 00-4.26-3.8c-1.14-.14-2.3-.18-3.45-.21-1.38-.03-2.76-.01-4.24-.01v21.01c.27.03.59.09.9.09 2.47.03 4.95.08 7.42.06 5.19-.04 8.36-2.3 9.91-7.29.74-2.38 1.09-4.88 1.61-7.32l.23-1.01h1.49v17.35H.09c-.04-.2-.09-.36-.09-.52 0-.26.02-.52.04-.89l2.62-.34c1.83-.25 2.45-.84 2.74-2.68.06-.39.09-.79.09-1.18V8.87c0-.49-.05-.99-.13-1.47-.28-1.54-.9-2.14-2.47-2.38-.91-.14-1.83-.24-2.81-.36V3.24h34.37l-.01 15.15zm123.12 29.22v-1.39c.85-.12 1.68-.22 2.52-.35 2.06-.32 2.79-1.13 2.89-3.21.02-.39.02-.79.02-1.19V9.33c0-.69-.02-1.39-.14-2.06-.24-1.38-.88-1.98-2.27-2.23-.49-.09-.98-.16-1.47-.22-.48-.06-.97-.09-1.53-.15V3.21c.4-.02.75-.06 1.1-.06 6.33 0 12.66-.03 18.99.01 3.64.02 7.24.33 10.67 1.72 3.76 1.52 6.19 4.12 6.5 8.29.31 4.09-1.34 7.31-4.73 9.61-2.45 1.66-5.21 2.48-8.11 2.95-3.31.54-6.64.39-9.96.19-.36-.02-.71 0-1.18 0-.02.39-.05.73-.05 1.08v14.44c0 .56.05 1.12.13 1.67.24 1.69 1.05 2.5 2.75 2.72.85.11 1.7.16 2.56.25.32.03.64.08 1.02.13v1.4h-19.71zm13.31-42.52v18.87c.91.08 1.75.23 2.6.23 1.87-.01 3.77.08 5.61-.18 3.44-.48 5.89-2.38 6.98-5.76.72-2.23.78-4.54.38-6.84-.56-3.28-2.56-5.27-5.76-6.02-3.22-.75-6.48-.35-9.81-.3zm-33.45 27.57c-.28 6.58-2.94 11.69-9.07 14.42-9.26 4.12-20.41-1.21-21.71-12.09-.79-6.62 1.29-12.13 7.1-15.7 9.17-5.63 21.92-.66 23.46 11.06.11.78.15 1.57.22 2.31zm-8.19-.59c-.11-1.38-.21-3.46-.47-5.51a12.45 12.45 0 00-1.72-5.21c-2.34-3.68-7.97-3.69-10.2.06a13.45 13.45 0 00-1.42 3.76c-.88 3.82-.76 7.72-.52 11.6.14 2.2.52 4.37 1.44 6.42 1.71 3.78 5.49 4.17 8.13 3.12 1.82-.72 2.78-2.25 3.43-4 1.12-3.09 1.18-6.32 1.33-10.24zm133.29.44c-.25 6.63-2.86 11.67-8.86 14.48-8.2 3.84-18.93.08-21.54-9.95-1.97-7.57 1.12-15.46 8.45-18.68 8.75-3.86 19.56.59 21.62 11.08.21 1.06.24 2.16.33 3.07zm-8.22-.46c-.07-1.04-.12-2.72-.29-4.39-.23-2.17-.64-4.31-1.81-6.21a6.09 6.09 0 00-10.27-.07 12.68 12.68 0 00-1.65 4.93c-.58 3.8-.56 7.61-.19 11.43.19 1.9.57 3.77 1.39 5.53 1.59 3.41 4.88 4.11 7.8 3.16 2.11-.69 3.14-2.4 3.82-4.37 1.03-3.04 1.12-6.21 1.2-10.01zM213.51 1.28V.01h13.23c.02.27.07.52.07.77-.05 2.47-.15 4.94-.15 7.41-.02 11.31-.01 22.61-.01 33.92 0 .4 0 .79.02 1.19.1 1.72.8 2.51 2.48 2.79.58.1 1.17.17 1.84.27v1.28h-16.18v-1.27c.66-.1 1.31-.18 1.95-.29 1.59-.28 2.28-1.05 2.38-2.66.03-.53.04-1.05.04-1.58V6.14c0-.53-.01-1.06-.04-1.58-.11-1.53-.76-2.35-2.26-2.72-.76-.19-1.56-.27-2.34-.39-.32-.07-.63-.11-1.03-.17zM65.32 37.36l1.42.29a13.17 13.17 0 01-3.55 7.43c-2.42 2.51-5.44 3.49-8.87 3.34-4.34-.2-8.01-1.78-10.69-5.31a14.76 14.76 0 01-2.79-7.2c-.53-4.13-.11-8.14 2.14-11.73 3.36-5.34 8.32-7.55 14.55-7.07 1.87.14 3.65.62 5.21 1.67 2.53 1.7 3.69 4.08 3.3 7.12-.3 2.3-2.1 3.84-4.24 3.75-2.12-.09-3.65-1.52-3.81-3.56a3.86 3.86 0 013.17-4.16l.95-.17a4.58 4.58 0 00-3.09-2.51c-3.73-.98-7.32.16-8.88 4.33-.53 1.44-.9 2.97-1.08 4.5-.44 3.68-.47 7.37.45 11 .25.98.62 1.95 1.07 2.86 2.45 4.99 8.72 4.71 11.63 1.63a11.28 11.28 0 002.68-5.1l.23-.86c.03-.07.09-.11.2-.25zm148.1 9v1.26h-16.18v-1.25l1.85-.28c1.67-.28 2.34-.99 2.5-2.68.04-.46.05-.92.05-1.38v-18.1c0-.79-.04-1.58-.15-2.37a2.2 2.2 0 00-1.71-1.96c-.86-.22-1.73-.37-2.66-.57v-1.19h12.03c.04.21.1.4.1.58l-.21 18.2c-.02 2.04-.02 4.09 0 6.13.03 2.36.67 3.06 3.04 3.43l1.34.18zM205.32.72c2.55 0 4.7 2.09 4.72 4.61a4.78 4.78 0 01-4.75 4.7 4.75 4.75 0 01-4.65-4.69 4.65 4.65 0 014.68-4.62zm-64.56 32.89V29.3h18.37v4.31h-18.37zm144.88-14.24v-1.63h-7.97V8.88h-7.46v8.77c.03.04-4.95.01-5.4.04v1.71h5.42v1.35c0 6.03-.03 12.07.02 18.1.01 1.37.17 2.77.47 4.11a6.54 6.54 0 003.1 4.41 7.5 7.5 0 0011-4.19c.58-1.79.6-3.63.64-5.48.02-.85 0-1.7 0-2.58h-1.51l-.05.95c-.06 1.58-.07 3.16-.2 4.74a5.76 5.76 0 01-1.4 3.52 2.7 2.7 0 01-2.68.9c-1.06-.23-1.6-.99-1.78-2.01a7.88 7.88 0 01-.16-1.37c-.01-7.15.03-22.04.06-22.46 2.66-.02 5.27-.02 7.9-.02z"/></svg></a></div><div class="gnt_n_sm gnt_n_sm__ne gnt_n_nc__hbn"><a class="gnt_n_sm_a gnt_n_sm__ne_a" data-u-sr="anon reg" href="https://subscribe.echo-pilot.com/specialoffer?gps-source=CPTILELEFT&itm_campaign=2021SUMMERFUN&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.echo-pilot.com%2Fstory%2Fnews%2F2021%2F07%2F26%2Fgreencastle-mans-book-encompasses-daughters-addiction-death-legacy-opioids-fentanyl-leah-straley%2F8090203002%2F" target=_blank rel=noopener data-t-l=":tiffany tile (left nanobar)|p|c|${n}$1 for 6 Months. Save 98%." elementtiming=nav-submsg></a></div><div class="gnt_n_sm gnt_n_nc__hbn"><a class=gnt_n_sm_a data-u-sr="anon reg" href="https://subscribe.echo-pilot.com/specialoffer?gps-source=CPMASTHEAD&itm_campaign=2021SUMMERFUN&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.echo-pilot.com%2Fstory%2Fnews%2F2021%2F07%2F26%2Fgreencastle-mans-book-encompasses-daughters-addiction-death-legacy-opioids-fentanyl-leah-straley%2F8090203002%2F" target=_blank rel=noopener data-t-l=":tiffany tile (right masthead)|p|c|${m}$1 for 6 Months. Save 98%." elementtiming=nav-submsg></a></div><nav class=gnt_n_mn aria-label="Global navigation"><a class="gnt_n_mn_l gnt_n_mn_l__fi gnt_n_mn_ce gnt_n_mn_l__se" href=/news/ data-t-l=:n|v|c|news elementtiming=nav-item>News</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/sports/ data-t-l=:n|v|c|sports>Sports</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/entertainment/ data-t-l=:n|v|c|entertainment>Entertainment</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/lifestyle/ data-t-l=:n|v|c|lifestyle>Lifestyle</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=/opinion/ data-t-l=:n|v|c|opinion>Opinion</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://www.usatoday.com/ data-t-l=:n|v|c|nation-world>USA TODAY</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://www.legacy.com/obituaries/therecordherald/ data-t-l=:n|v|c|obituaries>Obituaries</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://user.echo-pilot.com/user/enewspaper/ data-t-l=:n|v|c|e-edition>E-Edition</a> <a class="gnt_n_mn_l gnt_n_mn_ce" href=https://www.publicnoticepa.com/ data-t-l=:n|v|c|legals>Legals</a><div class=gnt_n_dd_w data-g-r="nav_ce nav_sh"><button class="gnt_n_dd_bt gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navgdp data-g-ltn=navgd data-t-l=:m|v|g|caret aria-label="Global Navigation" aria-haspopup=true aria-expanded=false><svg class=gnt_n_dd_bt_svg viewBox="0 0 10 6"><path d="M5 3.35L8.64 0 10 1.4 5 6 0 1.4 1.36 0z"/></svg></button></div><div class=gnt_n_us><div class=gnt_n_se data-g-r=nav_ce><a class="gnt_n_se_a gnt_n_mn_ce" data-g-r=nav_ab data-g-tn=navse href=/search/ data-t-l=:r|r|g|icon title=Search aria-label=Search aria-haspopup=true aria-expanded=false><svg class=gnt_n_se_a_svg viewBox="0 0 24 24"><path d="M15.75 14.33l4.96 4.96-1.42 1.42-4.96-4.96a6.5 6.5 0 1 1 1.41-1.41zM10.5 15a4.5 4.5 0 1 0 0-9 4.5 4.5 0 0 0 0 9z"/></svg></a></div><a class="gnt_n_wt gnt_n_mn_ce" href=/weather/ target=_blank rel="external noopener" aria-label="Weather in Greencastle" title="Weather in Greencastle" data-t-l=:n|v|c|weather></a> <a class=gnt_n_us_sb data-u-sr="anon reg" href="https://subscribe.echo-pilot.com/specialoffer?gps-source=CPTOPNAVBAR&itm_campaign=2021SUMMERFUN&itm_medium=ONSITE&onSuccessRedirectURL=https%3A%2F%2Fwww.echo-pilot.com%2Fstory%2Fnews%2F2021%2F07%2F26%2Fgreencastle-mans-book-encompasses-daughters-addiction-death-legacy-opioids-fentanyl-leah-straley%2F8090203002%2F" target=_blank rel=noopener data-t-l=:n|p|c|subscribe elementtiming=nav-subbt>Subscribe</a></div></nav></header><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__hi"><div id=ad-slot-7103-pa-greencastle-C6639-high_impact-news-1 class="gnt_x_sl gnt_x_hi"></div></aside><div class=gnt_bc></div><div class=gnt_cw_w><a class=gnt_cw_sl data-g-r=base_xbutton href=/news/ data-t-l=:b|v|c|overlay aria-label=Close aria-hidden=true tabindex=-1></a> <a class="gnt_cw_sl gnt_cw_sl__ed" data-g-r=base_xbutton href=/news/ data-t-l=:b|v|c|overlay aria-label=Close aria-hidden=true tabindex=-1></a><main class=gnt_cw><div class=gnt_ar_lbl aria-label=News data-c-ssts=NEWS></div><article class=gnt_pr><h1 class=gnt_ar_hl elementtiming=ar-headline>A daughter's overdose death leads to 'The CALLing'</h1><div class=gnt_ar_by><a href=/staff/3477739001/shawn-hardy/ class="gnt_ar_by_a gnt_ar_by_a__fi">Shawn Hardy</a><div class=gnt_ar_pb>Echo Pilot</div></div><div class=gnt_ar_dt aria-label="Published: 8:50 a.m. ET Jul. 26, 2021 Updated: 2:37 p.m. ET Jul. 26, 2021"></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.echo-pilot.com/story/news/2021/07/26/greencastle-mans-book-encompasses-daughters-addiction-death-legacy-opioids-fentanyl-leah-straley/8090203002/ data-ss-t="A daughter's overdose death leads to 'The CALLing'" data-ss-d="&#34;The CALLing&#34; by Mike Straley is about his daughter Leah, her struggle with addiction, her death and how he and his wife Robin help women in recovery."><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=281271339617085&href=https%3A%2F%2Fwww.echo-pilot.com%2Fstory%2Fnews%2F2021%2F07%2F26%2Fgreencastle-mans-book-encompasses-daughters-addiction-death-legacy-opioids-fentanyl-leah-straley%2F8090203002%2F" data-g-r=base_si data-ss-a=f data-t-l=:h|v|c|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.echo-pilot.com%2Fstory%2Fnews%2F2021%2F07%2F26%2Fgreencastle-mans-book-encompasses-daughters-addiction-death-legacy-opioids-fentanyl-leah-straley%2F8090203002%2F&text=A%20daughter's%20overdose%20death%20leads%20to%20'The%20CALLing'&via=undefined" data-g-r=base_si data-ss-a=t data-t-l=:h|v|c|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=A%20daughter's%20overdose%20death%20leads%20to%20'The%20CALLing'%20-%20from%20Echo%20Pilot&body=A%20daughter's%20overdose%20death%20leads%20to%20'The%20CALLing'%0A%0A%22The%20CALLing%22%20by%20Mike%20Straley%20is%20about%20his%20daughter%20Leah%2C%20her%20struggle%20with%20addiction%2C%20her%20death%20and%20how%20he%20and%20his%20wife%20Robin%20help%20women%20in%20recovery.%0A%0ACheck%20out%20this%20story%20on%20echo-pilot.com%3A%20https%3A%2F%2Fwww.echo-pilot.com%2Fstory%2Fnews%2F2021%2F07%2F26%2Fgreencastle-mans-book-encompasses-daughters-addiction-death-legacy-opioids-fentanyl-leah-straley%2F8090203002%2F" data-t-l=:h|v|c|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=:h|v|c|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><div class=gnt_ar_b><aside class="gnt_em gnt_em__fp gnt_em_vp__tp gnt_em__el" aria-label="Video - Mila Kunis and Glenn Close on new film 'Four Good Days'"><div class=gnt_em_vp_w data-g-r=vp_tp data-c-vt=teal data-t-pl=teal-hero><button class="gnt_em_vp_a gnt_em_vp__tp_a" data-g-r="vp_ap vp_tg" data-c-vpattrs="{&#34;muted&#34;:true,&#34;bContent&#34;:false,&#34;an&#34;:&#34;pa-greencastle-C6639&#34;,&#34;pn&#34;:&#34;Echo Pilot&#34;,&#34;vidNum&#34;:1,&#34;docking&#34;:true}" data-c-vpdata="{&#34;adsEnabled&#34;:true,&#34;awsPath&#34;:&#34;news/national&#34;,&#34;byline&#34;:&#34;&#34;,&#34;canonicalURL&#34;:&#34;&#34;,&#34;contentSourceCode&#34;:&#34;APDM&#34;,&#34;createDate&#34;:&#34;2021-05-01T01:22:15Z&#34;,&#34;credit&#34;:&#34;AP&#34;,&#34;duration&#34;:82000,&#34;headline&#34;:&#34;Mila Kunis and Glenn Close on new film 'Four Good Days'&#34;,&#34;hlsURL&#34;:&#34;https://hlsmedia.gannett-cdn.com/authoring/video-renditions/94a7eea1-c25c-4ee1-9463-1c193b5d615f/9247d843-38e3-4d37-902b-cfd76d17fa3d/1080p_30fps,720p_30fps,480p_30fps,master.m3u8?subtitles=4899064001&#34;,&#34;id&#34;:&#34;4899064001&#34;,&#34;image&#34;:{&#34;url&#34;:&#34;https://www.gannett-cdn.com/authoring/video-thumbnails/94a7eea1-c25c-4ee1-9463-1c193b5d615f_poster.jpg&#34;,&#34;opto&#34;:true},&#34;initialPublishDate&#34;:&#34;2021-05-01T01:22:15Z&#34;,&#34;keywords&#34;:&#34;USAT Video&#34;,&#34;mp4URL&#34;:&#34;https://downloadmedia.gannett-cdn.com/authoring/video-renditions/94a7eea1-c25c-4ee1-9463-1c193b5d615f/9247d843-38e3-4d37-902b-cfd76d17fa3d/1080p_30fps.mp4&#34;,&#34;origin&#34;:&#34;AP Domestic&#34;,&#34;pageURL&#34;:{&#34;long&#34;:&#34;https://www.usatoday.com/videos/news/nation/2021/05/01/mila-kunis-and-glenn-close-new-film-four-good-days/4899064001/&#34;},&#34;promoBrief&#34;:&#34;Glenn Close and Mila Kunis talk about the toll of addiction in new film \&#34;Four Good Days.\&#34; \&#34;It decimates families,\&#34; says Close. (April 30)&#34;,&#34;propertyName&#34;:&#34;USATODAY&#34;,&#34;publishDate&#34;:&#34;2021-05-01T01:22:15Z&#34;,&#34;series&#34;:&#34;&#34;,&#34;ssts&#34;:{&#34;section&#34;:&#34;news&#34;,&#34;subsection&#34;:&#34;nation&#34;,&#34;topic&#34;:&#34;&#34;,&#34;subtopic&#34;:&#34;&#34;},&#34;tags&#34;:[{&#34;id&#34;:&#34;68532648-1f35-4dac-a1dd-26cd518c074d&#34;,&#34;name&#34;:&#34;USAT Video&#34;}],&#34;title&#34;:&#34;Mila Kunis and Glenn Close on new film 'Four Good Days'&#34;,&#34;url&#34;:&#34;/videos/news/nation/2021/05/01/mila-kunis-and-glenn-close-new-film-four-good-days/4899064001/&#34;}" aria-label="Play video"><img alt class=gnt_em_vp_img src="https://www.gannett-cdn.com/authoring/video-thumbnails/94a7eea1-c25c-4ee1-9463-1c193b5d615f_poster.jpg?width=660&height=371&fit=crop&format=pjpg&auto=webp" data-g-r=vp_po elementtiming=ar-lead-image decoding=async /><svg class=gnt_em_vp_svg><use xlink:href=#gnt_svg_video_play /></svg></button><div class=gnt_em_vp_c><button class=gnt_em_vp_db aria-label="Close docked video player"><svg class=gnt_em_vp_db_svg viewBox="0 0 16 16"><path d="M9 7.625L13.125 3.5 14.5 4.875 10.375 9l4.125 4.125-1.375 1.375L9 10.375 4.875 14.5 3.5 13.125 7.625 9 3.5 4.875 4.875 3.5 9 7.625z"/></svg></button><div class=teal-video-wrap><video poster="https://www.gannett-cdn.com/authoring/video-thumbnails/94a7eea1-c25c-4ee1-9463-1c193b5d615f_poster.jpg?width=660&height=371&fit=crop&format=pjpg&auto=webp" title="Mila Kunis and Glenn Close on new film 'Four Good Days'" muted playsinline elementtiming=ar-lead-video></video></div></div></div><div class=gnt_em_vt data-c-et="Mila Kunis and Glenn Close on new film 'Four Good Days'"></div><div class="gnt_em_vb gnt_em_vb__te" aria-label="Glenn Close and Mila Kunis talk about the toll of addiction in new film &#34;Four Good Days.&#34; &#34;It decimates families,&#34; says Close. (April 30)" data-c-credit=AP></div></aside><p class=gnt_ar_b_p>At 9:02 a.m. Feb. 14, 2018, Mike Straley got "The CALL" that forever changed life for him and his wife, Robin.</p><p class=gnt_ar_b_p>"The CALLing" is what the Greencastle couple has done following the death of their 26-year-old daughter, Leah Renee Straley, from a fentanyl overdose on that Valentine's Day morning.</p><p class=gnt_ar_b_p>"The CALLing" also is the title of his book about their daughter, her struggle with addiction and quest for sober living, her death, their grief and how Leah's Legacy Foundation is truly her legacy.</p><p class=gnt_ar_b_p>"If this book helps maybe a father, mom, sister or brother going through this, it was worth writing," said Mike, who worked with Christian Faith Publishing on the book, which came out this spring.</p><h2 class=gnt_ar_b_h2>'The CALL'</h2><p class=gnt_ar_b_p>Mike, executive director of the Fulton County Medical Center Foundation in McConnellsburg, was in his office when his phone rang at 9:02 a.m. on Valentine's Day 2018. It was a call from the medical center's front desk. Two Pennsylvania State Police officers were there and wanted to see him, he recounts in the first chapter.</p><figure class="gnt_em gnt_em_img"><img class=gnt_em_img_i style=height:440px data-g-r=lazy data-gl-src="https://www.gannett-cdn.com/presto/2021/07/26/NECP/ce91506f-1997-4dcd-b451-1eebcb4eef1d-mike_straley_signing_book.jpg?width=660&height=440&fit=crop&format=pjpg&auto=webp" data-gl-srcset="https://www.gannett-cdn.com/presto/2021/07/26/NECP/ce91506f-1997-4dcd-b451-1eebcb4eef1d-mike_straley_signing_book.jpg?width=1320&height=880&fit=crop&format=pjpg&auto=webp 2x" decoding=async alt="Mike Straley signs a copy of 'The CALLing,' his book about his daughter Leah's struggle with addiction, the grief of losing a child and what he and his wife Robin are doing to help women in recovery."/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="Mike Straley signs a copy of 'The CALLing,' his book about his daughter Leah's struggle with addiction, the grief of losing a child and what he and his wife Robin are doing to help women in recovery." data-c-credit="Provided Photo"></div></figure><p class=gnt_ar_b_p>They asked to meet with him privately. He took them to a conference room, and they told him of Leah's death early that morning in Delray Beach, Fla. She was visiting a friend she had met at a sober living facility in California.</p><p class=gnt_ar_b_p>He writes heart-breakingly of the drive from McConnellsburg to the Herald-Mail in Hagerstown, where his wife works in advertising, and telling her, "We lost her, Rob. We lost her. We lost Leah."</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-pa-greencastle-C6639-native-article_link-news-2 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>"I'm laying it all out there ... sharing Leah's journey and being as transparent as possible," Mike said in a recent interview.</p><p class=gnt_ar_b_p>That forthrightness strikes nerves when the couple speak to women in sober living homes while distributing Leah's Legacy bags.</p><p class=gnt_ar_b_p>"Recovery stories are great, but over half a million died (of opioid overdoses) in the last decade," Mike said. "Families are grieving and hurt. We share the impact on us as parents. It can be raw for them."</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-pa-greencastle-C6639-native-article_link-news-3 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>"We're very transparent and open to discuss anything," Robin added. "Our visits and talks linger amongst residents. They continue to hold conversations long after we have left."</p><h2 class=gnt_ar_b_h2>'If it weren't for Leah ...'</h2><p class=gnt_ar_b_p>Mike and Robin were supposed to have dinner with Leah in Delray Beach on March 1, 2018, but instead they held her memorial service at Covenant Life Church, Hagerstown.</p><aside class="gnt_em gnt_em_anc" id=gnt_atomsnc data-g-r=lazy data-gl-method=loadAnc aria-label="Newsletter signup form"></aside><p class=gnt_ar_b_p>Two testimonials Pastor Tim Fisher shared at the service showed them a side of their daughter they did not know about.</p><p class=gnt_ar_b_p>One woman Leah met in sober living facility in California wrote, "If it weren't for Leah, I wouldn't be where I am today. There were countless times I wanted to leave and just give up, but Leah was always there to guide me back and help me through some of the most difficult times of my life."</p><p class=gnt_ar_b_p>The owner of a sober living home in California, a mentor and friend of Leah's, wrote, "Without exception, when we would have a new client, who was scared, nervous about being sober or just being in a new environment, Leah would be who I would turn to. She would welcome the newcomer with open arms, never having met her, yet greet her with her endearing smile, soft voice and that gentle way about her. Leah had a positive genius for making others who suffered from her same addiction feel safe, welcomed and accepted."</p><h2 class=gnt_ar_b_h2>'The CALLing'</h2><p class=gnt_ar_b_p>After their loss, the Straleys looked for different ways to cope — family and friends; support groups; talking with other parents; getting involved in Brooke's House, a sober living home now open outside of Hagerstown; and participating in addiction education events.</p><p class=gnt_ar_b_p>Knowing how Leah helped others in sober living combined with memories of a call from her just before Christmas 2017 led to the creation of Leah's Legacy bags and the nonprofit Leah's Legacy Foundation.</p><figure class="gnt_em gnt_em_img gnt_em_img__inset"><img class=gnt_em_img_i style=height:400px data-g-r=lazy data-gl-src="https://www.gannett-cdn.com/presto/2021/07/26/NECP/e28fcec8-310a-46f1-b33a-2ea53b1a0b88-mike_straley_book_leah_pic_on_sign.jpg?width=300&height=400&fit=crop&format=pjpg&auto=webp" data-gl-srcset="https://www.gannett-cdn.com/presto/2021/07/26/NECP/e28fcec8-310a-46f1-b33a-2ea53b1a0b88-mike_straley_book_leah_pic_on_sign.jpg?width=600&height=800&fit=crop&format=pjpg&auto=webp 2x" decoding=async alt="Leah Straley is remembered with signs, plaques and a memorial garden at the Leah's Legacy Operations Center."/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="Leah Straley is remembered with signs, plaques and a memorial garden at the Leah's Legacy Operations Center." data-c-credit="Shawn Hardy"></div></figure><p class=gnt_ar_b_p>Two months before she died, Leah called her parents from a sober living home and excitedly told them about the Christmas gift bag she received from a church group. It contained a purse loaded with toiletries and other personal care items, gift cards, winter gloves, hat, scarf and more.</p><p class=gnt_ar_b_p>"We needed to recreate the bag and serve others like she had been served," Mike writes.</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-pa-greencastle-C6639-native-article_link-news-4 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>The bags are purple — Leah's favorite color and the color of overdose awareness. They are filled with personal care items, pens and notebooks, snacks, socks and other items and are intended to provide hope, joy and love to women in sober living homes and support groups. Many women enter sober living homes with nothing, the Straleys explained.</p><p class=gnt_ar_b_p>They initially stored supplies and packed the bags in their home, but in October 2020, the Leah's Legacy Operations Center opened next door, behind his parents' home on Grant Shook Road.</p><p class=gnt_ar_b_p>The COVID-19 pandemic put the brakes on distribution of Leah's Legacy bags, but provided more time for fundraising, and when the center opened it had been wholly paid for with donations and gifts-in-kind.</p><figure class="gnt_em gnt_em_img"><img class=gnt_em_img_i style=height:495px data-g-r=lazy data-gl-src="https://www.gannett-cdn.com/presto/2021/07/26/NECP/356239de-fcb4-4a06-bbce-f2224e37d655-mike_straley_book_leahs_robin_straley.jpg?width=660&height=495&fit=crop&format=pjpg&auto=webp" data-gl-srcset="https://www.gannett-cdn.com/presto/2021/07/26/NECP/356239de-fcb4-4a06-bbce-f2224e37d655-mike_straley_book_leahs_robin_straley.jpg?width=1320&height=990&fit=crop&format=pjpg&auto=webp 2x" decoding=async alt="Robin Straley is shown at the opening of Leah's Legacy Operations Center in October 2020."/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="Robin Straley is shown at the opening of Leah's Legacy Operations Center in October 2020." data-c-credit="Shawn Hardy"></div></figure><p class=gnt_ar_b_p>After restrictions eased in November, the Straleys made up for lost time, visiting five sober living homes in five weeks, including two in one day. To date, they have distributed more than 300 Leah's Legacy bags.</p><h2 class=gnt_ar_b_h2>'Agape Love'</h2><p class=gnt_ar_b_p>The book talks about addiction, recovery, relapse, their struggle to do the right thing, find the right help, the right rehab, Robin said.</p><p class=gnt_ar_b_p>"We couldn't fix Leah, Leah had to fix herself," Mike said.</p><p class=gnt_ar_b_p>"Leah said that many times, 'Mom, this is not your problem, it's my problem,'" Robin said. "But as parents you always try to help."</p><p class=gnt_ar_b_p>Leah helped women in sober living homes with encouragement, and Mike said, "I think she would be proud of what we're trying to do."</p><figure class="gnt_em gnt_em_img"><img class=gnt_em_img_i style=height:495px data-g-r=lazy data-gl-src="https://www.gannett-cdn.com/presto/2021/07/26/NECP/85c54023-3670-46fc-a02b-72da2d5103cb-mike_straley_with_helen_overly.jpg?width=660&height=495&fit=crop&format=pjpg&auto=webp" data-gl-srcset="https://www.gannett-cdn.com/presto/2021/07/26/NECP/85c54023-3670-46fc-a02b-72da2d5103cb-mike_straley_with_helen_overly.jpg?width=1320&height=990&fit=crop&format=pjpg&auto=webp 2x" decoding=async alt="Mike Straley, right, talks with Helen Overly at the Leah's Legacy Operations Center opening in October 2020."/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="Mike Straley, right, talks with Helen Overly at the Leah's Legacy Operations Center opening in October 2020." data-c-credit="Shawn Hardy"></div></figure><p class=gnt_ar_b_p>Readers of "The CALLing" learn about the final days of Leah's life and Robin's persistent, but unsuccessful pursuit of charges in the chapter titled the "The Investigation."</p><p class=gnt_ar_b_p>They get eye-opening lessons in "Addiction Education 101," which begins "Addiction does not discriminate" and concludes "The years 2010-2020 — the decade we lost half a million Americans to the opioid crisis."</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-pa-greencastle-C6639-native-article_link-news-5 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>Good times and bad with "Leahbug" are remembered in the chapter bearing her name.</p><p class=gnt_ar_b_p>The couple's love for their daughter is evident throughout the book that concludes with the chapter "Agape Love."</p><p class=gnt_ar_b_p>Agape love is selfless love, love that takes action, courage, strength and sacrifice, Mike writes, applying each of those words to their life with Leah and their life since her death.</p><p class=gnt_ar_b_p><a href=/story/news/2021/02/05/narcan-naloxone-black-balloon-day-opioid-addiction-next-distro-prevention-point-pittsburgh/4410624001/ target=_blank rel=noopener data-t-l=":b|e|inline click|${u}" class=gnt_ar_b_a>Black Balloon Day: Overdose reversal drug by mail could 'literally save a life'</a></p><p class=gnt_ar_b_p><a href=/story/news/2020/10/19/leahs-legacy-leah-straley-addiction-fentanyl/5982820002/ target=_blank rel=noopener data-t-l=":b|e|inline click|${u}" class=gnt_ar_b_a>Leah's Legacy: Bags provide hope for women in recovery</a></p><p class=gnt_ar_b_p>"Agape love is always loving our daughter, Leah Renee Straley, forever twenty-six, who has provided us with the action, courage, strength and sacrifice to do the right thing, to be our best and to help build better futures for women who want to lead drug-free and productive lives."</p><h2 class=gnt_ar_b_h2>'What's Next'</h2><p class=gnt_ar_b_p>"I want to speak to people — groups of people — from school assemblies to people in recovery to grieving parents," Mike writes in the chapter "What's Next."</p><p class=gnt_ar_b_p>"I will travel to share Leah's story, our story as parents ... I want to share what Robin and I are doing. I want to share this book. I want to listen to parents who carry the same burden. I want to share their tears. I want to give them a heartfelt hug. I have a message and I want to share it with the masses ... I let my heart carry the message. It is, after all, the heart that has the hole and needs mending."</p><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__al"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-pa-greencastle-C6639-native-article_link-news-6 class="gnt_x_sl gnt_x_al"></div></aside><p class=gnt_ar_b_p>Mike will be signing copies of "The CALLing" at the following:</p><ul class=gnt_ar_b_ul><li class=gnt_ar_b_ul_li>Home Run Derby event to benefit Noah's House, Norlo Park, Fayetteville, Saturday, Aug. 7, 8 a.m. to 2 p.m.</li><li class=gnt_ar_b_ul_li>State Line United Methodist Church, Sunday, Aug. 8, 10:30 a.m. (discussion and book signing)</li><li class=gnt_ar_b_ul_li>Greencastle-Antrim Chamber of Commerce, Tuesday, Aug. 31, 4 to 6 p.m. commemorating Overdose Awareness Day</li><li class=gnt_ar_b_ul_li>Sober September Challenge, Cowans Gap State Park, Pavilion #4, Saturday, Sept. 25, 4 to 7 p.m.</li></ul><figure class="gnt_em gnt_em_img"><img class=gnt_em_img_i style=height:440px data-g-r=lazy data-gl-src="https://www.gannett-cdn.com/presto/2021/07/26/NECP/503ce67b-0555-4ea5-892a-15b464f73ed2-mike_straley_book_cover.jpg?width=660&height=440&fit=crop&format=pjpg&auto=webp" data-gl-srcset="https://www.gannett-cdn.com/presto/2021/07/26/NECP/503ce67b-0555-4ea5-892a-15b464f73ed2-mike_straley_book_cover.jpg?width=1320&height=880&fit=crop&format=pjpg&auto=webp 2x" decoding=async alt="In 'The CALLing,' Mike Straley writes about his daughter Leah's struggle with addiction, the grief of losing a child and what he and his wife Robin are doing to help women in recovery."/><div class="gnt_em_img_ccw gnt_em_img_ccw__cap gnt_em_img_ccw__crd" data-c-caption="In 'The CALLing,' Mike Straley writes about his daughter Leah's struggle with addiction, the grief of losing a child and what he and his wife Robin are doing to help women in recovery." data-c-credit="Provided Photo"></div></figure><p class=gnt_ar_b_p>To schedule a book signing or speaking engagement, call 717-552-8885 or email MLStraley81@gmail.com</p><p class=gnt_ar_b_p>Copies of the book are available to purchase on the home page of Leah's Legacy Foundation, <a href=https://www.leahslegacy.net target=_blank rel=noopener data-t-l=":b|e|inline click|${u}" class=gnt_ar_b_a>www.leahslegacy.net</a>, through PayPal.</p><p class=gnt_ar_b_p>Books also can be ordered by sending a check or money order payable to Leah's Legacy to 10631 Grant Shook Road Greencastle, PA 17225, along with the shipping address.</p><p class=gnt_ar_b_p>The cost is $20 plus $4 for shipping and handling.</p><p class=gnt_ar_b_p>"Robin and I are on the road to recovery, not from addiction, but the experiencing the loss of our daughter," Mike wrote. "We will never fully recover, but we want to offer hope and love to the millions of grieving parents and women in addiction. It is what Leah Renee Straley would want us to do."</p><h2 class=gnt_ar_b_h2>Where to find help</h2><p class=gnt_ar_b_p>Franklin/Fulton Drug & Alcohol at 717-263-1256 or ffda@franklincountypa.gov</p><p class=gnt_ar_b_p>Wellspan's 1-844-WARMLINE</p><p class=gnt_ar_b_p>PA Get Help Now, 1-800-662-HELP (4357).</p></div><div class=gnt_ss data-g-r=base_sc data-ss-u=https://www.echo-pilot.com/story/news/2021/07/26/greencastle-mans-book-encompasses-daughters-addiction-death-legacy-opioids-fentanyl-leah-straley/8090203002/ data-ss-t="A daughter's overdose death leads to 'The CALLing'" data-ss-d="&#34;The CALLing&#34; by Mike Straley is about his daughter Leah, her struggle with addiction, her death and how he and his wife Robin help women in recovery."><a class=gnt_ss_a href="https://www.facebook.com/dialog/share?display=popup&app_id=281271339617085&href=https%3A%2F%2Fwww.echo-pilot.com%2Fstory%2Fnews%2F2021%2F07%2F26%2Fgreencastle-mans-book-encompasses-daughters-addiction-death-legacy-opioids-fentanyl-leah-straley%2F8090203002%2F" data-g-r=base_si data-ss-a=f data-t-l=:i|v|c|facebook aria-label="Share to Facebook" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_facebook /></svg></a><a class=gnt_ss_a href="http://twitter.com/share?url=https%3A%2F%2Fwww.echo-pilot.com%2Fstory%2Fnews%2F2021%2F07%2F26%2Fgreencastle-mans-book-encompasses-daughters-addiction-death-legacy-opioids-fentanyl-leah-straley%2F8090203002%2F&text=A%20daughter's%20overdose%20death%20leads%20to%20'The%20CALLing'&via=undefined" data-g-r=base_si data-ss-a=t data-t-l=:i|v|c|twitter aria-label="Share to Twitter" rel=noreferrer><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_twitter /></svg></a><a class=gnt_ss_a href="mailto:?subject=A%20daughter's%20overdose%20death%20leads%20to%20'The%20CALLing'%20-%20from%20Echo%20Pilot&body=A%20daughter's%20overdose%20death%20leads%20to%20'The%20CALLing'%0A%0A%22The%20CALLing%22%20by%20Mike%20Straley%20is%20about%20his%20daughter%20Leah%2C%20her%20struggle%20with%20addiction%2C%20her%20death%20and%20how%20he%20and%20his%20wife%20Robin%20help%20women%20in%20recovery.%0A%0ACheck%20out%20this%20story%20on%20echo-pilot.com%3A%20https%3A%2F%2Fwww.echo-pilot.com%2Fstory%2Fnews%2F2021%2F07%2F26%2Fgreencastle-mans-book-encompasses-daughters-addiction-death-legacy-opioids-fentanyl-leah-straley%2F8090203002%2F" data-t-l=:i|v|c|email aria-label="Share by email"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_share_email /></svg></a><button class="gnt_ss_a gnt_ss_a__sa" data-g-r=base_si data-ss-a=s data-t-l=:i|v|c|shareapi aria-label="Share natively"><svg class=gnt_ss_a_svg><use xlink:href=#gnt_svg_shareapi /></svg></button></div><div class="gnt_tb gnt_tbb"><div id=gnt_tbw_1></div></div></article><div class=gnt_rr><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__pf"><div id=ad-slot-7103-pa-greencastle-C6639-poster-news-7 class="gnt_x_sl gnt_x_p"></div></aside><div class="gnt_tb gnt_tbr" data-t-l=":taboola (article rail)|e|taboola click"><div id=gnt_tbw_2></div></div><div class="gnt_m gnt_m_fs"><a href="https://cm.echo-pilot.com/site-feedback/?platform=Tangent-Desktop&url=https%3A%2F%2Fwww.echo-pilot.com%2Fstory%2Fnews%2F2021%2F07%2F26%2Fgreencastle-mans-book-encompasses-daughters-addiction-death-legacy-opioids-fentanyl-leah-straley%2F8090203002%2F&marketName=echo-pilot&cta=Right-Rail" class=gnt_m_fs_a data-t-l=":survey|v|c|We're always working..." aria-label="We're always working to improve your experience. Let us know what you think."></a></div><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__st"><div data-g-r=lazy data-gl-method=lazyLoadX id=~ad-slot-7103-pa-greencastle-C6639-poster_scroll-news-8 class="gnt_x_sl gnt_x_sl__st gnt_x_p"></div></aside></div><div class=gnt_xbr><a class=gnt_ar_xb data-g-r=base_xbutton href=/news/ data-t-l=:b|v|c|x aria-label=Close></a></div></main></div><footer class=gnt_ft data-g-r="lazy lazy_p" data-gl-type=method data-gl-method=shbd><aside aria-label=advertisement class="gnt_m gnt_x gnt_x__lbl gnt_x__lb"><div id=ad-slot-7103-pa-greencastle-C6639-leaderboard_btf-news-9 class=gnt_x_lb></div></aside><svg class="gnt_ft_lg gnt__hbd" data-g-r=lazy_c alt="Echo Pilot - Part of the USA Today Network"><use xlink:href=#gnt_svg_lg alt/></svg><div class="gnt_ft_lw gnt__hbd" data-g-r=lazy_c><div class=gnt_ft_ls aria-label=About><a href=http://www.gannett.com/careers/ class=gnt_ft_a data-t-l=:f|v|c|about:careers>Careers</a> <a href=https://cm.echo-pilot.com/accessibility/ class=gnt_ft_a data-t-l=:f|v|c|about:accessibility>Accessibility</a> <a href=https://www.echo-pilot.com/sitemap/ class=gnt_ft_a data-t-l=:f|v|c|about:site-map>Site Map</a> <a href=https://www.publicnoticepa.com/ class=gnt_ft_a data-t-l=:f|v|c|about:legals>Legals</a> <a href=https://cm.echo-pilot.com/ethical-conduct/ class=gnt_ft_a data-t-l=:f|v|c|about:our-ethical-principles>Our Ethical Principles</a> <a href=https://cm.echo-pilot.com/terms/ class=gnt_ft_a data-t-l=:f|v|c|about:terms-of-service>Terms of Service</a> <a href=https://cm.echo-pilot.com/privacy/ class=gnt_ft_a data-t-l=:f|v|c|about:privacy-policy>Privacy Policy</a> <a href=https://cm.echo-pilot.com/privacy-policy/ class=gnt_ft_a data-t-l=:f|v|c|about:california-privacy-right>Your California Privacy Rights / Privacy Policy</a><button class="gnt_ft_a gnt_ft_a__bl" data-g-r=base_ottid data-t-l=:f|v|c|about:cookie-policy>Do Not Sell My Info / Cookie Policy</button><a href=https://www.echo-pilot.com/contact/staff/ class=gnt_ft_a data-t-l=:f|v|c|about:staff-directory>Staff Directory</a></div><div class=gnt_ft_ls aria-label=Support><a href=https://help.echo-pilot.com class=gnt_ft_a data-t-l=:f|v|c|support:contact-us>Contact Us</a> <a href=https://supportlocal.usatoday.com/ class=gnt_ft_a data-t-l=:f|v|c|support:support-local-businesses>Support Local Business</a> <a href=https://localiq.com/markets/pennsylvania/ class=gnt_ft_a data-t-l=:f|v|c|support:advertise-your-business>Advertise Your Business</a> <a href=https://cm.echo-pilot.com/advertising-terms-conditions class=gnt_ft_a data-t-l=:f|v|c|support:advertising-terms-and-conditions>Advertising Terms and Conditions</a> <a href=https://imagn.com/licensing-reprints/ class=gnt_ft_a data-t-l=:f|v|c|support:licensing-and-reprints>Licensing & Reprints</a> <a href=https://help.echo-pilot.com/ class=gnt_ft_a data-t-l=:f|v|c|support:help-center>Help Center</a> <a href=https://account.echo-pilot.com/ class=gnt_ft_a data-t-l=:f|v|c|support:my-account>My Account</a> <a href=https://cm.echo-pilot.com/site-feedback/ class=gnt_ft_a data-t-l=:f|v|c|support:feedback>Give Feedback</a></div><div class=gnt_ft_ls aria-label="Stay Connected"><a href=https://subscribe.echo-pilot.com/ class=gnt_ft_a data-t-l=:f|v|c|stay-connected:subscribe-today>Subscribe Today</a> <a href=https://profile.echo-pilot.com/newsletters/manage class=gnt_ft_a data-t-l=:f|v|c|stay-connected:newsletters>Newsletters</a> <a href=https://www.facebook.com/GreencastleEchoPilot/ class=gnt_ft_a data-t-l=:f|v|c|stay-connected:facebook>Facebook</a> <a href="http://nl.newsbank.com/nl-search/we/Archives?p_product=EPGG&p_theme=gatehouse&p_action=keyword" class=gnt_ft_a data-t-l=:f|v|c|stay-connected:archives>Archives</a></div><div class=gnt_ft_ls aria-label="Our Partners"><a href=/jobs class=gnt_ft_a data-t-l=:f|v|c|our-partners:jobs>Jobs</a> <a href=/section/cars class=gnt_ft_a data-t-l=:f|v|c|our-partners:cars>Cars</a> <a href=/homes class=gnt_ft_a data-t-l=:f|v|c|our-partners:homes>Homes</a> <a href=http://www.marketplaceadsonline.com/marketplace/paway class=gnt_ft_a data-t-l=:f|v|c|our-partners:classifieds>Classifieds</a> <a href=https://www.billeriq.com/ebpp/GHM384/Login/Index class=gnt_ft_a data-t-l=:f|v|c|our-partners:pay-your-ad-bill>Pay Your Ad Bill</a> <a href=https://www.reviewed.com/ class=gnt_ft_a data-t-l=:f|v|c|our-partners:reviewed>Reviewed.com</a> <a href=https://www.10best.com/ class=gnt_ft_a data-t-l=:f|v|c|our-partners:10best>10Best</a> <a href=http://www.reachlocal.com/us/en class=gnt_ft_a data-t-l=:f|v|c|our-partners:reach-local>Reach Local</a></div></div><div class=gnt_ft_cr elementtiming=footer-cr>© 2021 www.echo-pilot.com. All rights reserved.</div></footer><script>if(gnt.luxEnabled&&(LUX={ae:[],al:[]},setTimeout(function(){gnt.addScript('/tangstatic/js/perf-q1a2z3ffa38c70.min.js',!0)},3E3),addEventListener("error",a=>{LUX.ae.push(a)}),"function"===typeof PerformanceObserver))try{LUX.al.po=new PerformanceObserver(a=>{LUX.al.push(...a.getEntries())}),LUX.al.po.observe({type:"longtask",buffered:!0})}catch(a){};</script><script>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</script><script async src=/tangstatic/js/main-q1a2z31304cff7.min.js onerror="document.querySelectorAll('.gnt__hbd').forEach(e=>e.classList.remove('gnt__hbd'))"></script><script type="gnt/tmpl" data-tmpl-key=navgdp><div class="gnt_n_dd_oy gnt_n_dd__sz" data-g-r=nav_oy></div><div class="gnt_n_dd gnt_n_dd__sz" data-g-r="nav_dd nav_te nav_ff" tabindex=0></div>|styles|[data-g-s=nav_ao] .gnt_n_dd_bt_svg{transform:rotate(180deg);background:currentColor;fill:#303030}.gnt_n_dd_oy{display:none;left:0;right:0;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px))}.gnt_n_dd{overscroll-behavior-y:contain;overflow:auto;overflow-x:hidden;box-sizing:border-box;display:none;width:385px;height:calc(var(--gnt-vh,100vh) - 100px - var(--gnt-sh,0px));margin:0 0 0 -20px;padding:7px 20px 0 32px;border-top:5px solid #0098fe;background:#303030;color:#fff}[data-g-s=nav_ao] .gnt_n_dd__sz{display:block;position:absolute}</script><script type="gnt/tmpl" data-tmpl-key=navse><form class=gnt_n_se_fm data-g-r=nav_dd action=/search/ role=search><input class=gnt_n_se_fm_qr data-g-r=nav_pf name=q placeholder="What can we help you find?" mozactionhint=search enterkeyhint=search aria-label="Search query"/><button class=gnt_n_se_fm_sm data-t-l=${se}:r|r|u| aria-label=Submit><svg class=gnt_n_se_fm_sm_svg viewBox="0 0 18 18"><path d="M12.28 9.76H2V7.74h10.28l-2.23-2.31L11.43 4 16 8.75l-4.57 4.75-1.38-1.43 2.23-2.31z"/></svg></button></form>|styles|.gnt_n_se_fm{display:none;align-items:center;justify-content:center;position:absolute;left:0;right:0;height:180px;padding:0 0 15px;border-top:5px solid #0098fe;background:#303030}[data-g-s~=nav_ao] .gnt_n_se_fm{display:flex}.gnt_n_se_fm_qr{width:492px;height:46px;padding:0 50px 0 0;border-style:solid;border-width:0 0 2px;border-color:#fff;border-radius:0;outline:0;background:0 0;color:#fff;font:700 28px 'Unify Sans','Helvetica Neue','Arial Nova',Helvetica,Arial,sans-serif}.gnt_n_se_fm_qr::placeholder{opacity:1;color:#fff}.gnt_n_se_fm_qr:-webkit-autofill{box-shadow:inset 0 46px #303030;-webkit-text-fill-color:#fff}.gnt_n_se_fm_sm{width:60px;height:50px;border:0;margin:0 -15px 0 -45px;padding:0;outline-offset:-8px;fill:#fff;background:0 0;cursor:pointer}.gnt_n_se_fm_sm:hover{fill:#e0e0e0}.gnt_n_se_fm_sm_svg{width:42px;height:42px;margin-top:3px;stroke:#303030;stroke-width:.5px}</script><link rel=preload as=fetch type=application/json crossorigin=use-credentials href=/global-q1a2z3Hw0uWMBrIrCwB3y1gtaN4+yjWxo.min.json /><link rel=dns-prefetch href=//images.taboola.com /><link rel=preconnect href=https://images.taboola.com /><script type=application/ld+json>[{"@context":"http://schema.org","@type":"NewsArticle","headline":"A daughter's overdose death leads to 'The CALLing'","description":"\"The CALLing\" by Mike Straley is about his daughter Leah, her struggle with addiction, her death and how he and his wife Robin help women in recovery.","url":"https://www.echo-pilot.com/story/news/2021/07/26/greencastle-mans-book-encompasses-daughters-addiction-death-legacy-opioids-fentanyl-leah-straley/8090203002/","mainEntityOfPage":{"@type":"WebPage","@id":"https://www.echo-pilot.com/story/news/2021/07/26/greencastle-mans-book-encompasses-daughters-addiction-death-legacy-opioids-fentanyl-leah-straley/8090203002/"},"thumbnailUrl":"https://www.gannett-cdn.com/presto/2021/07/26/NECP/ce91506f-1997-4dcd-b451-1eebcb4eef1d-mike_straley_signing_book.jpg?crop=3840,3840,x576,y0&width=150&height=150&format=pjpg&auto=webp","image":{"@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2021/07/26/NECP/ce91506f-1997-4dcd-b451-1eebcb4eef1d-mike_straley_signing_book.jpg?crop=5759,3240,x0,y292&width=1600&height=800&format=pjpg&auto=webp","height":800,"width":1600},"datePublished":"2021-07-26T12:50:28Z","dateCreated":"2021-07-26T12:50:28Z","dateModified":"2021-07-26T18:37:12Z","articleSection":"news","publisher":{"@type":"Organization","name":"Echo Pilot","logo":"https://www.echo-pilot.com/sitelogos/m-oc.svg"},"author":["Shawn Hardy"],"keywords":["access:free","ssts:news","type:story","tag:Greencastle, PA","tag:Valentine's Day","tag:Death and Dying","tag:Opioids","tag:Fentanyl","tag:Drug Addiction","tag:Recovery","tag:Overall Neutral"],"isAccessibleForFree":true,"isPartOf":{"@type":["CreativeWork","Product"],"name":"Echo Pilot - Unlimited Digital Access","productID":"echo-pilot.com:standard"},"metadata":"{\"id\":\"8090203002\",\"siteCode\":\"NECP\",\"contentSourceCode\":\"NECP\",\"ssts\":\"news\",\"type\":\"story\"}"},{"@context":"http://schema.org","@type":"VideoObject","name":"Mila Kunis and Glenn Close on new film 'Four Good Days'","description":"Glenn Close and Mila Kunis talk about the toll of addiction in new film \"Four Good Days.\" \"It decimates families,\" says Close. (April 30) AP","thumbnailUrl":"https://www.gannett-cdn.com/authoring/video-thumbnails/94a7eea1-c25c-4ee1-9463-1c193b5d615f_poster.jpg?width=1280&height=720&fit=crop&format=pjpg&auto=webp","uploadDate":"2021-05-01T01:22:15Z"},{"@context":"http://schema.org","@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2021/07/26/NECP/ce91506f-1997-4dcd-b451-1eebcb4eef1d-mike_straley_signing_book.jpg","caption":"Mike Straley signs a copy of 'The CALLing,' his book about his daughter Leah's struggle with addiction, the grief of losing a child and what he and his wife Robin are doing to help women in recovery.","copyrightHolder":"Provided photo"},{"@context":"http://schema.org","@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2021/07/26/NECP/e28fcec8-310a-46f1-b33a-2ea53b1a0b88-mike_straley_book_leah_pic_on_sign.jpg","caption":"Leah Straley is remembered with signs, plaques and a memorial garden at the Leah's Legacy Operations Center.","copyrightHolder":"Shawn Hardy"},{"@context":"http://schema.org","@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2021/07/26/NECP/356239de-fcb4-4a06-bbce-f2224e37d655-mike_straley_book_leahs_robin_straley.jpg","caption":"Robin Straley is shown at the opening of Leah's Legacy Operations Center in October 2020.","copyrightHolder":"Shawn Hardy"},{"@context":"http://schema.org","@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2021/07/26/NECP/85c54023-3670-46fc-a02b-72da2d5103cb-mike_straley_with_helen_overly.jpg","caption":"Mike Straley, right, talks with Helen Overly at the Leah's Legacy Operations Center opening in October 2020.","copyrightHolder":"Shawn Hardy"},{"@context":"http://schema.org","@type":"ImageObject","url":"https://www.gannett-cdn.com/presto/2021/07/26/NECP/503ce67b-0555-4ea5-892a-15b464f73ed2-mike_straley_book_cover.jpg","caption":"In 'The CALLing,' Mike Straley writes about his daughter Leah's struggle with addiction, the grief of losing a child and what he and his wife Robin are doing to help women in recovery.","copyrightHolder":"Provided photo"}]</script></body></html>