
<!DOCTYPE html>
<!--==================================================
==================START: HEADER====================-->
<html lang="en">
	<head>
		
		<!--
macro: mainmeta (MCD 201610140350)
current date: 20200312021241
template: 
currentrequest: /apps/pbcs.dll/article?avis=PA&date=20200312&category=ENTERTAINMENTLIFE&lopenr=200319709&Ref=AR
currentrequestunmodified: /entertainmentlife/20200312/erie-society-celebrates-irish-heritage
@templatetype: /apps/pbcs.dll/article?avis=PA&date=20200312&category=ENTERTAINMENTLIFE&lopenr=200319709&Ref=AR
@pagetype: article
app version: 2.0.433
-->
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1.0">
<meta property="og:site_name" content="Echo Pilot - Greencastle, PA" />
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" /> 
<meta name="msvalidate.01" content="7E15F9269E2CE66F2A488ABB04B5015E" />

		<title> Erie society celebrates Irish heritage - Entertainment & Life - Echo Pilot - Greencastle, PA - Greencastle, PA</title>
<!-- Meta Tags - Global Article6 guid: D8A4CEF5-3380-4BC4-B69B-4798818AB7C5-->
<meta name="description" content="" />
<meta property="bt:pubDate" content="20200312T00:05:32Z">
<meta property="bt:modDate" content="20200312T00:05:00Z">
<meta property="bt:author" content="Kristin Bowers / For the Erie Times-News">
<meta name="twitter:title" content="Erie society celebrates Irish heritage">
<meta name="twitter:description" content="The local Irish Cultural Society marks its 40th anniversary this year.
">
<meta property="og:title" content="Erie society celebrates Irish heritage"/>
<meta property="og:description" content="The local Irish Cultural Society marks its 40th anniversary this year.
" />
<meta name="author" content="Kristin Bowers / For the Erie Times-News">
	<meta name="twitter:card" content="summary_large_image">
	<meta name="twitter:image" content="https://www.echo-pilot.com/storyimage/PA/20200312/ENTERTAINMENTLIFE/200319709/AR/0/AR-200319709.jpg&MaxW=1200&MaxH=630">
	<meta property="og:image" content="https://www.echo-pilot.com/storyimage/PA/20200312/ENTERTAINMENTLIFE/200319709/AR/0/AR-200319709.jpg">
	<meta property="og:image:width" content="3648">
	<meta property="og:image:height" content="1934">
	<meta property="vf:unique_id" content="sitePA-pub385-D8A4CEF5-3380-4BC4-B69B-4798818AB7C5">
	<link rel="canonical" href="https://www.echo-pilot.com/entertainmentlife/20200312/erie-society-celebrates-irish-heritage"/>
<link rel="amphtml" href="https://www.echo-pilot.com/entertainmentlife/20200312/erie-society-celebrates-irish-heritage?template=ampart">
<script type="application/ld+json">
  {
    "@context": "http://schema.org",
    "@type": "NewsArticle",
    "mainEntityOfPage": {
		"@type": "WebPage",
		"@id": "https://www.echo-pilot.com/entertainmentlife/20200312/erie-society-celebrates-irish-heritage"
	},
    "headline": "Erie society celebrates Irish heritage",
    "image": {
       "@type": "ImageObject",
       	"url":"https://www.echo-pilot.com/storyimage/PA/20200312/ENTERTAINMENTLIFE/200319709/AR/0/AR-200319709.jpg",
       	"height": 1934,
       	"width": 3648
    },
    "url": "https://www.echo-pilot.com/article/20200312/ENTERTAINMENTLIFE/200319709",
    "thumbnailUrl": "https://www.echo-pilot.com/apps/pbcsi.dll/bilde?Site=PA&Date=20200312&Category=ENTERTAINMENTLIFE&ArtNo=200319709&Ref=AR",
    "author": [{"@type":"Person","name":"Kristin Bowers / For the Erie Times-News"}],
    "creator": "Kristin Bowers / For the Erie Times-News",
    "publisher": {
       "@type": "Organization",
       "name": "Echo Pilot - Greencastle, PA",
       "logo": {
         "@type": "ImageObject",
         "url": "https://www.echo-pilot.com/Global/images/head/nameplate/pa-echo-pilot_logo.png"
       }
    },
    "articleSection": "Entertainment & Life",
    "keywords": ["Community","Carousel / Featured","MSN Feed","Newsletter","PA_Erie - goerie.com","Local Entertainment","ATM Mature Families"],
    "isAccessibleForFree": "False",
	"hasPart":
	{
		"@type": "WebPageElement",
		"isAccessibleForFree": "False",
		"cssSelector" : ".paywall-is-accessible-for-free"
	},
	"isPartOf": {
    "@type": ["CreativeWork", "Product"],
    "name" : "Echo Pilot",
    "productID": "echo-pilot.com:standard"
	}
  }
</script>
<meta property="fb:app_id" content="143435942403889"/>
<meta name="twitter:site" content="@PatFridgenEP">
<meta property="og:type" content="article"/>
<meta property="article:opinion" content="false"/>

		<script type="text/javascript">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</script>
				        <link rel="stylesheet" type="text/css" href="https://fonts.googleapis.com/css?family=Oswald:300,400,700|Roboto+Condensed:400,400i,700,700i|Crimson+Text:400,400i,700,700i|Rubik:400,500,700,900" crossorigin="anonymous" />
        <link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/font-awesome/4.7.0/css/font-awesome.min.css" type="text/css" crossorigin="anonymous" />
        <link rel="stylesheet" href="//cdn.gatehousemedia.com/assets/css/2.0.433/default.min.css" type="text/css" crossorigin="anonymous" />
		<style type="text/css">
	/*legacy-header*/
	.legacy-header #baseLeaderboard {
		margin-top:25px;
	}
	#header-content div#slidingBillboard.ad.text-center {
		padding: 0;
		margin: 0;
	}
	#article > div > section.article-v2-left > div.ad-container { clear: both; }
	@media only screen and (max-width: 768px) {
		#buckets > div.article-extra > h4.chatter-title {
		    font-size: 2em;
		}
	}
	section.article-v2-right > div.article-body.p402_premium > div.vendor-logo.byline-item > img{
		max-width: 150px;
	}
	#apoc-breaking-wrapper{position: relative;z-index:100;}
	article.summary .inner .related li {max-height:fit-content!important;}
    /*==== ARTICLE ======*/
		/*==== for taboola ======*/
    	.article-newsletter-signup,#dialog-message{
	    	display: none !important;;
    	}
    	@media only screen and (min-width: 768px) {
			#interstitial{display:none;}
		}
		#header-main-center{
			display: none;
		}
    	/*story strip article ad*/
    	/* cssUpdates branch*/
    	div.gh-slider-storyStrip > div.adInject > div > iframe {
			max-height:90px;
		}
    	/* cssUpdates branch*/
    	.gh-slider-caption h3:not(.is-truncated):not([style="word-wrap: break-word;"]){
			-webkit-line-clamp: 4;
		    text-overflow: ellipsis;
    	}
    	.article-meta-day,a:visited  {
			font-family: "Roboto Condensed","Helvetica Neue","Helvetica","Roboto","Arial",sans-serif;
			font-size: 18.662px;
			font-weight: bold;
			color: #698096;
			display: block;
			font-kerning: normal;
			text-rendering: optimizeLegibility;
			margin-bottom: 10px;
			text-decoration: none;
		}
		#flipp-promo {
		    max-width: 300px;
		    margin: 0 auto;
		    max-height: 250px;
		 }
    	/* Viafoura email & password fields in registration/signup screens */
	 	.viafoura .vf-forgot-pw-link, .viafoura .vf-account-form {
	 		display: none;
	 	}
    	/*  TERMS OF SERVICE LINK - under viafoura comments submit button */
    	.vf-terms-of-service { margin-left: 12px;}
		/* TOUT MID ARTICLE PLAYER */
		.tout-mid-article { display:block; margin-right:2.35%; width:100%; }
	/* MOBILE article story stack */
    .gh-article-storyStack {
        background-color: #f3f3f3;
        display: inline-block;
        width: 100%;
        height: 150vw;
    }
    .gh-stacked {
        display: inline-block;
        padding: 2vw 2vw 4vw 2vw;
        margin: 0 0 3vw 0;
        height: 25vw;
        width: 100%;
    }
    .gh-stacked figure {
        width: 20vw;
        height: 20vw;
        display: inline-block;
        float: left;
        /* margin: 0 3vw 0 0; */
    }
    .gh-stacked h3 {
        width: calc(100% - 4.8em - 1.618em);
	    font-size: 1.25em;
	    line-height: 1.3em;
	    float: left;
	    display: inline;
    }
    .gh-article-storyStack .slick-slide .image{min-height:80px !important;}
    .gh-article-storyStack .slick-slide a{display:block;height:100%;width:100%;border-bottom: 1px solid #454545;margin-bottom:5px;}
</style>
		<style>
@media screen and (min-width: 768px){
	figure > a > div.teaser > span.native-thumbnail-dateline  {color:lightskyblue;}
}
@media screen and (max-width: 767px){
	figure > a > div.teaser > span.native-thumbnail-dateline  {color:#039be5;}
}
</style>
				<script type="text/javascript">
			window.supportsLocalStorage = false;
			try {
				window.supportsLocalStorage = !!window.localStorage
				    && typeof localStorage.getItem === 'function'
				    && typeof localStorage.setItem === 'function'
				    && typeof localStorage.removeItem === 'function';
			} catch(e) {
				console.error('localStorage error', e);
			}
			if(window.supportsLocalStorage === false) {
				console.warn('localStorage is not supported on this browser.');
			}
		</script>
		<script src="https://cdnjs.cloudflare.com/ajax/libs/jquery/2.1.4/jquery.min.js?20160411-3" crossorigin="anonymous"></script>
		<!-- Google Tag Manager -->
<script>
  //PAGE DATA
  __gh__coreData.pageData.type2 = "Article";
  __gh__coreData.pageData.error = __gh__coreData.pageData.type2 == "404" ? "404" : undefined;
  //USER
  __gh__coreData.user = {id:undefined,accessLevel:undefined};
  // Get clientside pieces from LocalStorage object
  if (window.supportsLocalStorage === true && typeof localStorage['_vxData'] != "undefined"){
    var _vxDataObj = JSON.parse(localStorage['_vxData']);
    __gh__coreData.user				= _vxDataObj;
  }
  //define main dataLayer for object for GTM
  window.dataLayer 	= window.dataLayer || [];
  dataLayer.push(__gh__coreData);
var __gh__gtm = {
	id:'GTM-WF5MZJ9'
};
(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer',__gh__gtm.id);
</script>
<!-- End Google Tag Manager -->
		<script async='async' src='//cdn.adsafeprotected.com/iasPET.1.js'></script>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({article:'auto'});
  !function (e, f, u, i) {
    if (!document.getElementById(i)){
      e.async = 1;
      e.src = u;
      e.id = i;
      f.parentNode.insertBefore(e, f);
    }
  }(document.createElement('script'),
  document.getElementsByTagName('script')[0],
  '//cdn.taboola.com/libtrc/gannett-network/loader.js',
  'tb_loader_script');
  if(window.performance && typeof window.performance.mark == 'function')
    {window.performance.mark('tbl_ic');}
</script>
		<!--[if lte IE 9]>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv.min.js"></script>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/html5shiv/3.7.3/html5shiv-printshiv.min.js"></script>
			<script src="https://cdnjs.cloudflare.com/ajax/libs/respond.js/1.4.2/respond.min.js"></script>
		<![endif]-->
		<!-- Begin comScore Tag -->
<script>
  var _comscore = _comscore || [];
  _comscore.push({ c1: "2", c2: "9289482" });
  (function() {
    var s = document.createElement("script"), el = document.getElementsByTagName("script")[0]; s.async = true;
    s.src = (document.location.protocol == "https:" ? "https://sb" : "http://b") + ".scorecardresearch.com/beacon.js";
    el.parentNode.insertBefore(s, el);
  })();
</script>
<noscript>
  <img src="http://b.scorecardresearch.com/p?c1=2&c2=9289482&cv=2.0&cj=1" />
</noscript>
<!-- End comScore Tag -->

		
	</head>
<!--================================================
==================END: HEADER====================-->

	<body class="__PAGETYPE__">
		          
	<div id="fb-root"></div>
	
		<a href="#" id="backToTop"><i class="fa fa-chevron-up"></i></a>
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-WF5MZJ9"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>

		<div id="wrapper-main">
			
					<header id="header-main" class="header header-expanded no-gutter static clearfix">
			<div id="toprail">
	<div class="inner clearfix">
		<a id="button-nav-toggle"
			title="Navigation menu">
			<span class="hidden-sm hidden-xs">Sections</span>
			<i class="fa fa-fw fa-bars"></i>
		</a>
			<ul id="toprail-nav-left" class="list-inline"><li><a href="https://www.echo-pilot.com/news" target="_top">News</a></li><li><a href="https://www.echo-pilot.com/sports" target="_top">Sports</a></li><li><a href="https://www.echo-pilot.com/entertainment" target="_top">Entertainment</a></li><li><a href="https://www.echo-pilot.com/lifestyle" target="_top">Life</a></li><li><a href="https://www.echo-pilot.com/obituaries" target="_top">Obituaries</a></li><li><a href="https://www.echo-pilot.com/section/cars" target="_top">Cars</a></li><li><a href="https://www.echo-pilot.com/jobs" target="_top">Jobs</a></li><li><a href="https://www.echo-pilot.com/homes" target="_top">Homes</a></li><li><a href="http://www.marketplaceadsonline.com/marketplace/paway" target="_blank">Classifieds</a></li></ul>
		<ul id="toprail-nav-right" class="list-inline">
				<li id="toprail-subscribe"><a href="https://www.echo-pilot.com/subscribe?g2i_source=echo-pilot.com&g2i_medium=subscribe&g2i_campaign=topRail" target="_top" class="btn btn-sm btn-subscribe hidden-lg">Subscribe</a></li>
			<li id="toprail-search" class="hidden-sm hidden-xs">
											<div id="toprail-search-form">
								<form class="search-bar input-group" role="search" name="siteSearchForm" method="get" action="/search">
									<script type="text/javascript">
	function searchArchive(archval){
		if(archval == 'archive'){
			document.location.href = 'http://nl.newsbank.com/nl-search/we/Archives?p_product=EPGG&p_theme=gatehouse&p_action=keyword';
		}else{
			return false;
		}
	}
</script>
<div class="input-group-btn">
	<button type="button" class="btn btn-default dropdown-toggle" data-toggle="dropdown" aria-haspopup="true" aria-expanded="false"><span class="caret"></span></button>
	<ul class="dropdown-menu" id="searchparam_dd">
		<li data-type="site" class="selected">Site</li>
<li data-type="archive">Archive</li>
	</ul>
</div><!-- /btn-group -->
<script>
$(document).on('click', '#searchparam_dd li', function() {
	searchArchive($(this).data('type'));
});
</script>
									<input class="search-input" name="searchText" placeholder="Search this site" type="search">
									<button type="submit" class="fa fa-fw fa-lg fa-search"></button>
								</form>
							</div>
							<i class="fa fa-fw fa-lg fa-search"></i>
			</li>
				<li id="toprail-weather" class="hidden-xs" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.echo-pilot.com/section/?template=ajaxWeather" data-gh-fetch-html-dom="#toprail-weather"></li>
		</ul>
	</div>
</div>
						<div id="header-main-nameplate">
				<div id="header-main-left">
					<div id="header-main-logo">
						<a href="https://www.echo-pilot.com">
							<img class="mainheadnameplate" src="https://www.echo-pilot.com/Global/images/head/nameplate/pa-echo-pilot_logo.png"  alt="Echo Pilot - Greencastle, PA" />
						</a>
					</div>
				</div>
				<div id="header-main-center">
					<a href="https://www.echo-pilot.com/subscribe?g2i_source=echo-pilot.com&g2i_medium=subscribe&g2i_campaign=header" target="_top" class="btn btn-subscribe">Subscribe Now</a>
				</div>
				<div id="header-main-right" class="hidden-xs">
					<div id="header-main-promo" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.echo-pilot.com/section/?template=ajaxPromoWiz7" data-gh-fetch-html-dom="#header-main-promo"></div>
				</div>
			</div>
		</header>


<!--==================================================
==========================START: CONTENT===========-->
			<div id="content" class="clearfix">
				

<div class="alert"></div>
<div id="apoc-breaking-wrapper" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.echo-pilot.com/section/breaking_ajax?template=breaking_ajax2" data-gh-fetch-html-dom="#apoc-breaking-wrapper"></div>
<div data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://cdn.gatehousemedia.com/gh-sites/global/breaking/breaking-special.html"></div>

				<div class="ad ad-billboard text-center" id="baseLeaderboard" data-size-mapping="baseLeaderBillboardArticle"></div>
				<div id="wrapper" class="clearfix">
					<div id="buckets">
	<article class="full article-v2 loading" data-updated="20200312000532">
	<div class="inner">
		<h1 class="headline">Erie society celebrates Irish heritage</h1>
		<section class="article-v2-left">&nbsp;</section>
		<section class="article-v2-right">
			        <figure class="thumb">
            <img class="image" src="https://www.echo-pilot.com/storyimage/PA/20200312/ENTERTAINMENTLIFE/200319709/AR/0/AR-200319709.jpg&MaxH=200&MaxW=200" width="100%">
            <!--div class="image-caption">
                <div class="description">Blarney Rubble band members perform at a Hooley sponsored by the Irish Cultural Society of Erie at Perry Hi-Way Hose Co. last month in Summit Township. Band members, from near left to right, are Mike Hart, Tony Barry, Pam Verity and Ron Stubbe. [GREG WOHLFORD/ERIE TIMES-NEWS]</div>
                <div class="credit"></div>
            </div-->
        </figure>
			<div class="article-body">
				<span class="byline-item">
					By Kristin Bowers / For the Erie Times-News
				</span>
				<div class="article-meta">
					<div class="inner">
						<div class="article-meta-main">
							<h3 class="article-meta-day">Thursday</h3>
							<span class="article-meta-date">Mar&nbsp;12,&nbsp;2020&nbsp;at&nbsp;12:05&nbsp;AM</span>
							<span class="article-meta-updated"></span>
						</div>
					</div>
				</div>
				<br><br>
				<div class="inner">
					<p class="article-summary">The local Irish Cultural Society marks its 40th anniversary this year.</p>
					<p><p>You know what they say &#8211; everyone&#8217;s Irish on St. Patrick&#8217;s Day.</p><br><p>But some show their Irish pride every day: Cheryl Heintz sports silvery Celtic earrings. Peggy Vommaro wears a claddagh ring, heart out. Nita O&#8217;Toole has an Irish phrase tattooed on her wrist. And all are members of Erie&#8217;s Irish Cultural Society.</p><br><p>&#8220;It used to be us wearing green and shamrocks,&#8221; said Pat Wheeler, another society member. &#8220;But the more we learned about the traditions, then it became things like Irish knots and the Celtic cross.&#8221;</p><br><p>And that&#8217;s the goal of the Irish Cultural Society &#8211; to encourage an interest in learning about Irish heritage.</p><br><p>The organization, which celebrates its 40th anniversary this year, began when three Erie residents &#8211; Grace Fowler, Russell Vance and the Rev. Matthew Daly &#8211; bonded over their shared interest in Irish roots.</p><br><p>The founders wanted an organization that was inclusive and open to anyone interested in learning more about Ireland, Heintz explained &#8211; it&#8217;s not limited to Irish Catholics, or even to those of Irish heritage.</p><br><p>The organization&#8217;s early meetings included Irish history classes. Other activities over the years featured Irish language lessons, a children&#8217;s activities day and scholarships for students of St. Patrick School. Today, the Irish Cultural Society has a roster of more than 200, many of them long-time members.</p><br><p>Vommaro and Wheeler are charter members, meaning they&#8217;ve been there since the first year. Heintz isn&#8217;t far behind, with 38 years. O&#8217;Toole has been a member for about a dozen years.</p><br><p>The members still meet monthly &#8211; trivia night one month, movie night another month, a Taste of Ireland another. They&#8217;re also always trying out fresh ideas. One of their latest projects is learning ceili dancing &#8211; a type of Irish country dancing, pronounced &#8220;kaylee,&#8221; that Vommaro jokingly described as &#8220;Irish aerobics.&#8221;</p><br><p>They hope to be ready to do a demonstration of ceili dancing at the society&#8217;s 40th anniversary celebration in September, O&#8217;Toole said.</p><br><p>&#8220;It&#8217;s not like step dancing &#8211; it&#8217;s entirely different,&#8221; O&#8217;Toole  said. &#8220;In Ireland, you can get up and dance in any pub. That&#8217;s just what they do.&#8221;</p><br><p>Society members are also looking for fresh energy to join the group.</p><br><p>&#8220;Like every organization, we&#8217;re trying to get younger people involved,&#8221; Vommaro said. &#8220;We want the traditions to be carried on.&#8221;</p><br><p>Some of those traditions are often unseen in the Erie community. Though St. Patrick School is long closed, the society still funds scholarships &#8211; now, to high school students to attend a three-week cultural experience in Ireland. The group has donated to the Inner-City Neighborhood Art House and to the Sister Mary Pascal Gray, SSJ, Food Pantry. The society recently completed a nine-year project, erecting a memorial to Erie&#8217;s immigrants on the grounds of St. Patrick Catholic Church.</p><br><p>The society&#8217;s efforts are supported by an annual  fundraiser &#8211; an Irish Hooley, or party with music, dancing, food and fun. This year&#8217;s was held in February, with a turnout of several hundred guests.</p><br><p>&#8220;In Ireland, a &#8216;craic&#8217; (pronounced &#8216;crack&#8217;) is a really good time,&#8221; O&#8217;Toole said. &#8220;So we say our hooley is a craicing good time.&#8221;</p><br><p>And make no mistake &#8211; while the Irish Cultural Society members have their own projects, they are also very visible at some of the most public Irish events in Erie, including the annual St. Patrick&#8217;s Day Parade.</p><br><p>A float in the parade? Naturally.</p><br><p>The Irish wolfhounds that are a perennial parade favorite? Those are raised by an Irish Cultural Society member.</p><br><p>And the popular Rince na Tiarna dancers? They&#8217;re here thanks to the efforts of the Irish Cultural Society, too.</p><br><p>The society provided funding for Rince na Tiarna, an Irish dance school in Buffalo, to start offering classes in Erie in the mid-1980s. Rince na Tiarna now has an established presence in Erie and continues to train new generations of young people in traditional Irish step dancing.</p><br><p>Listening to Irish Cultural Society members reminisce about decades of activities and brainstorm ideas for the future, it&#8217;s clear that the group is as much about camaraderie as it is culture. It&#8217;s also about a shared pride of heritage coupled with a genuine interest in learning more about different traditions.</p><br><p>&#8220;We&#8217;re proud to be American &#8211; of course we are. We all came here for a reason,&#8221; Vommaro said. &#8220;But we also want to keep the Irish heritage alive.&#8221;</p><br><p>For information or to join the Irish Cultural Society, go to www.icserie.org.</p><br><p>Whether you&#8217;re Irish by blood or just Irish for the day, there are plenty of ways to celebrate St. Patrick&#8217;s Day in the Erie region:</p><br><p>&#8226; Curious About: Leprechauns & Irish Mythology: Blasco Library, 160 E. Front St., will hold this free event for ages 8-11 this Thursday from 5:30 to 6:45 p.m. The Emerald Isle is teeming with tales of leprechauns, fairies, banshees, werewolves and other mythological creatures. Learn more about these fascinating legends while snacking on Irish shortbread cookies, playing games, framing a real four-leaf clover and having a banshee screaming contest. Reservations required. Call 451-6932 or visit events.erielibrary.org.</p><br><p>&#8226; St. Patrick&#8217;s Day Parade: The granddaddy of St. Patrick&#8217;s Day festivities in Erie, the parade steps off Saturday at 2 p.m. It starts at 11th and State streets and ends at St. Patrick Church on East Fourth Street. The parade, now in its 43rd year, is hosted by the Knights and Ladies of St. Patrick and the Erie Zoo.</p><br><p>&#8226; St. Patrick&#8217;s Distance Festival: The Erie Runners Club&#8217;s annual celebration includes a 5K, a 10K and an option to run both races at Presque Isle State Park on Saturday. Registration and packet pickup begin at 7:30 a.m. For information, including registration fees, visit www.erierunners.club.</p><br><p>&#8226; St. Patrick's Day Family Party: Our Lady of the Lake Catholic Church, 128 Sunset Drive, Edinboro, will host its annual party Saturday at 6 p.m. Admission includes a traditional corned beef and cabbage dinner, entertainment featuring the Rince Na Tiarna Irish Dancers and music by Tennessee Backporch, games and more. Tickets are $15 in advance or $17 at the door for adults, $5 for ages 5-16 and free for younger. For more information, call 734-3113 or visit www.ololake.com.</p><br><p>&#8226; St. Patrick&#8217;s Day Weekend: Peek&#8217;n Peak Resort near Findley Lake, New York, is once again going green with a weekend of Irish-themed festivities. Events throughout this Saturday around the resort include a scavenger hunt, crafts and kid-friendly activities, games, music, whiskey tastings and more. On Sunday, the Main Ski Lodge will host a Bangers and Mash Party at 1 p.m. For information, call 716-355-4141 or visit www.pknpk.com/events.</p><br><p>&#8226; St. Patrick's Day Celebration and Trivia: This celebration Tuesday from 1:30 to 3:30 p.m. at LECOM Center for Health and Aging, 3910 Schaper Ave., will feature a meal of reubens and one side followed by  St. Patrick's Day themed trivia and prizes. Preregistration is required. Cost is $15 for members, $20 for nonmembers. For more information, call 453-5072 or visit www.lecomcha.org.</p></p>
				</div>
			</div>
		</section>
	</div>
</article>
</div>

				</div><!-- /wrapper -->
			</div><!-- /content -->

			<div id="push-main" class="clearfix"></div>
		</div><!-- /wrapper-main -->
<!--==================================================
====================END: CONTENT===================-->
				<footer id="footer-main" class="clearfix">
			<div class="inner container">
				<div id="footer-main-newsletter">
					<div id="footer-main-subscribe">
						<h2>Never miss a story</h2>
						<p>
							Choose the plan that's right for you.<br>
							Digital access or digital and print delivery.
						</p>
						<a href="https://www.echo-pilot.com/subscribe?g2i_source=echo-pilot.com&g2i_medium=subscribe&g2i_campaign=footer" target="_top" class="btn btn-subscribe">Subscribe Now</a>
					</div>
								<h2>Sign up for daily e-mails</h2>
										<form id="sfNewsletterForm_footer" class="sfNewsletterForm form-inline">
			<input type="email" name="sfUserEmail" class="sfUserEmail" placeholder="Enter Email Address">
			<input type="hidden" name="sfSource" class="sfSource" value="footer">
			<input type="submit" name="sfSignup" class="sfSignup btn btn-newsletter" value="Sign Up Now">
			<div class="sfResults">
			</div>
		</form>
				</div>
				<div id="footer-main-info" data-gh-accordion-loaded="false" data-gh-accordion-panel-dom="#footer-main-info .footer-col ul" data-gh-accordion-toggle-dom="#footer-main-info &gt; .footer-col &gt; h4" data-gh-accordion-open-at="480">	<div class="footer-col"><h4>Site Services<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://myprofile.echo-pilot.com/page.aspx?QS=c76003443ff9837d08393c4559ff8a1b86d1a2da672edbd7&PROD_CODE=NOMX_EP" target="_top">My Profile</a></li><li><a href="https://www.echo-pilot.com/contact" target="_top">About Us</a></li><li><a href="https://www.echo-pilot.com/subscribe" target="_top">Subscribe</a></li><li><a href="http://adportal.marketplaceadsonline.com/gatehouse-adportal/paway-classified/index.html" target="_blank">Place Ad</a></li><li><a href="https://www.echo-pilot.com/submit" target="_top">Online Forms</a></li></ul></div><div class="footer-col"><h4>Market Place<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://content.gatehousemedia.com/files/echo_pilot_house_ad.pdf" target="_blank">Holiday Advertising</a></li><li><a href="http://marketplace.echo-pilot.com/ROP/Categories.aspx" target="_blank">Shopping</a></li><li><a href="http://www.marketplaceadsonline.com/marketplace/paway" target="_blank">Classifieds</a></li><li><a href="http://mediakit.gatehousemedia.com/Greencastle_PA" target="_top">Advertise With Us</a></li><li><a href="https://www.echo-pilot.com/pay-your-ad-bill" target="_blank">Pay Your Ad Bill</a></li></ul></div><div class="footer-col"><h4>Community Info<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://www.greencastle.k12.pa.us/" target="_blank">Greencastle-Antrim School District</a></li><li><a href="http://www.rescuehose.com/" target="_blank">Rescue Hose Company No. 1</a></li><li><a href="http://www.greencastlepachamber.org/index.html" target="_blank">Greencastle-Antrim Chamber of Commerce</a></li><li><a href="http://www.oldhomeweek.org/" target="_blank">Greencastle-Antrim Old Home Week</a></li></ul></div><div class="footer-col"><h4>Communities<i class="fa fa-angle-down"></i></h4><ul><li><a href="http://www.greencastlepa.gov/" target="_blank">Borough of Greencastle</a></li><li><a href="http://www.twp.antrim.pa.us/?show=article&id=27&sid=1" target="_blank">Antrim Township</a></li><li><a href="http://www.co.franklin.pa.us/Pages/default.aspx" target="_blank">Franklin County</a></li></ul></div>
</div><!-- /footer-main-info -->
			</div><!-- /inner++++/apps/pbcs.dll/article?avis=PA&date=20200312&category=ENTERTAINMENTLIFE&lopenr=200319709&Ref=AR -->
			<div id="footer-main-copyright">
					<p id="footer-copyrightInfo">&copy; Gannett Co., Inc. 2020. All rights reserved.</p>
	<p>Original content available for non-commercial use under a Creative Commons license, except where noted.
	<br />Echo Pilot - Greencastle, PA  ~ 24 E. Baltimore St., Greencastle, PA 17225<span class="gdpr hide"> ~ <a id="ot-sdk-btn" class="ot-sdk-show-settings" href="javascript:void(0);">Do Not Sell My Personal Information</a> ~ <a href="https://www.echo-pilot.com/section/cookie-policy" target="_blank">Cookie Policy</a></span><span class="gdpr-disabled hide"> ~ <a href="https://www.gannett.com/cookie-policy/" target="_blank">Do Not Sell My Personal Information</a></span> ~ <a href="http://www.gannett.com/privacy-statement/" target="_blank">Privacy Policy</a> ~ <a href="http://www.gannett.com/terms-of-use/" target="_blank">Terms Of Service</a> ~ <a href="https://www.gannett.com/ccpa/" target="_blank">Your California Privacy Rights / Privacy Policy</a></p>
	<p><a href="/ownership">Gannett | USA TODAY NETWORK</a></p>
			</div>
		</footer><!-- /footer -->
				<nav id="drawer" role="navigation">
			<a href="https://www.echo-pilot.com/subscribe?g2i_source=echo-pilot.com&g2i_medium=subscribe&g2i_campaign=drawer" target="_top" class="btn btn-subscribe">Subscribe Now</a><hr>
			<div id="drawer-search" class="hidden-md hidden-lg">
				<form class="search-bar input-group" role="search" name="siteSearchForm" method="get" action="/search">
					<div class="input-group-btn">
						<button type="button"
							class="btn btn-default dropdown-toggle"
							data-toggle="dropdown"
							aria-haspopup="true"
							aria-expanded="false">
							<span class="caret"></span>
						</button>
						<ul class="dropdown-menu" id="searchparam_dd">
							<li data-type="site" class="selected">Site</li>
							<li data-type="archive">Archive</li>
						</ul>
					</div>
					<input class="search-input" name="searchText" placeholder="Search Site" type="search">
					<button type="submit" class="fa fa-fw fa-lg fa-search"></button>
				</form>
			</div>
			<hr class="hidden-md hidden-lg">
			<div class="inner">
				<div id="wrapper-drawer">
						<ul 
					 class="nav" 
					 data-gh-accordion-loaded="false" 
					 data-gh-accordion-panel-dom="#drawer-nav-sections .subnav" 
					 data-gh-accordion-toggle-dom="#drawer-nav-sections &gt; li &gt; a" 
					 id="drawer-nav-sections"
				   ><li><a href="https://www.echo-pilot.com" target="_top">Home</a></li><li><a href="https://www.echo-pilot.com/news"><span class="nav-category">News</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"5070"><a href="https://www.echo-pilot.com/news/community" target="_top">Community</a></li><li id="navLink-TEST-"5071"><a href="https://www.echo-pilot.com/news/court-news" target="_top">Court News</a></li><li id="navLink-TEST-"5072"><a href="https://www.echo-pilot.com/news/education" target="_top">Education</a></li><li id="navLink-TEST-"5073"><a href="https://www.echo-pilot.com/news/nation-world" target="_top">Nation & World</a></li><li id="navLink-TEST-"5074"><a href="https://www.echo-pilot.com/news/police-fire" target="_top">Police & Fire</a></li><li id="navLink-TEST-"5076"><a href="https://www.echo-pilot.com/news/state-news" target="_top">State News</a></li><li id="navLink-TEST-"5075"><a href="https://www.echo-pilot.com/news/shareable" target="_top">Shareable</a></li></ul></li><li><a href="https://www.echo-pilot.com/sports"><span class="nav-category">Sports</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"5079"><a href="https://www.echo-pilot.com/sports/high-school" target="_top">High School</a></li></ul></li><li><a href="https://www.echo-pilot.com/entertainment"><span class="nav-category">Entertainment</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"5082"><a href="https://www.echo-pilot.com/entertainment/books" target="_top">Books</a></li><li id="navLink-TEST-"5083"><a href="https://www.echo-pilot.com/entertainment/celebrity-news" target="_top">Celebrity News</a></li><li id="navLink-TEST-"5084"><a href="https://www.echo-pilot.com/entertainment/movies" target="_top">Movies</a></li><li id="navLink-TEST-"5085"><a href="https://www.echo-pilot.com/entertainment/music" target="_top">Music</a></li><li id="navLink-TEST-"38400"><a href="https://www.echo-pilot.com/calendar" target="_top">Calendar</a></li></ul></li><li><a href="https://www.echo-pilot.com/lifestyle"><span class="nav-category">Lifestyle</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"52270"><a href="http://www.timeandmoney.com" target="_top">Time and Money</a></li><li id="navLink-TEST-"5089"><a href="https://www.echo-pilot.com/lifestyle/boomers" target="_top">Boomers</a></li><li id="navLink-TEST-"5090"><a href="https://www.echo-pilot.com/lifestyle/faith" target="_top">Faith</a></li><li id="navLink-TEST-"5091"><a href="https://www.echo-pilot.com/lifestyle/family" target="_top">Family</a></li><li id="navLink-TEST-"5092"><a href="https://www.echo-pilot.com/lifestyle/food" target="_top">Food</a></li><li id="navLink-TEST-"5093"><a href="https://www.echo-pilot.com/lifestyle/health" target="_top">Health</a></li><li id="navLink-TEST-"5094"><a href="https://www.echo-pilot.com/lifestyle/home-garden" target="_top">Home & Garden</a></li><li id="navLink-TEST-"51628"><a href="https://www.echo-pilot.com/lifestyle/localexperts" target="_top">Local Experts</a></li><li id="navLink-TEST-"5095"><a href="https://www.echo-pilot.com/lifestyle/pets" target="_top">Pets</a></li><li id="navLink-TEST-"5096"><a href="https://www.echo-pilot.com/lifestyle/travel" target="_top">Travel</a></li></ul></li><li><a href="https://www.echo-pilot.com/opinion"><span class="nav-category">Opinion</span><span class="fa fa-angle-down"></span></a><ul class="subnav"><li id="navLink-TEST-"5099"><a href="https://www.echo-pilot.com/opinion/columns" target="_top">Columns</a></li><li id="navLink-TEST-"5100"><a href="https://www.echo-pilot.com/opinion/editorials" target="_top">Editorials</a></li><li id="navLink-TEST-"5101"><a href="https://www.echo-pilot.com/opinion/letters" target="_top">Letters</a></li></ul></li><li><a href="https://www.echo-pilot.com/business-news" target="_top">Business</a></li><li><a href="https://www.echo-pilot.com/obituaries" target="_top">Obituaries</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>More</header><li><a href="https://www.echo-pilot.com/photos" target="_top">Photos</a></li><li><a href="https://www.echo-pilot.com/videos" target="_top">Videos</a></li><li><a href="https://www.echo-pilot.com/calendar" target="_top">Calendar</a></li><li><a href="http://games.echo-pilot.com" target="_top">Games</a></li><li><a href="https://www.echo-pilot.com/contests" target="_top">Contests</a></li><li><a href="https://www.echo-pilot.com/ara" target="_top">Branded Content</a></li><li><a href="https://www.echo-pilot.com/submit" target="_top">Submit your news</a></li><li><a href="https://www.echo-pilot.com/section/promoted//?prx_adpz=2203" target="_top">From Our Advertisers</a></li><li><a href="https://www.echo-pilot.com/southern-kitchen" target="_top">Southern Kitchen</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>Subscriber</header><li><a href="http://myprofile.echo-pilot.com/page.aspx?QS=c76003443ff9837d08393c4559ff8a1b86d1a2da672edbd7&PROD_CODE=NOMX_EP" target="_top">My Profile</a></li><li><a href="https://www.echo-pilot.com/subscribe" target="_top">Subscribe</a></li></ul>
	<ul class="drawer-nav-secondary nav"><header>Market Place</header><li><a href="http://www.marketplaceadsonline.com/marketplace/paway" target="_blank">Classifieds</a></li><li><a href="http://www.easternarkansasshopping.com/ROP/Categories.aspx" target="_top">Find-N-Save</a></li><li><a href="https://www.echo-pilot.com/section/cars" target="_top">Cars</a></li><li><a href="https://www.echo-pilot.com/jobs" target="_top">Jobs</a></li><li><a href="https://www.echo-pilot.com/homes" target="_top">Homes</a></li><li><a href="http://adportal.marketplaceadsonline.com/gatehouse-adportal/paway-classified/index.html" target="_blank">Place Ad</a></li><li><a href="http://mediakit.gatehousemedia.com/Greencastle_PA" target="_top">Advertise With Us</a></li><li><a href="https://www.echo-pilot.com/pay-your-ad-bill" target="_blank">Pay Your Ad Bill</a></li><li><a href="http://echo-pilot.thrivehive.com/" target="_blank">Digital Marketing Services</a></li></ul>
<footer id="footer-drawer">
	<hr>
	<ul class="drawer-nav-secondary nav">
		<li>
			<a href="mailto:jnowell@echo-pilot.com">Feedback</a>
		</li>
		<li>
			<a href="/ownership">Ownership</a>
		</li>
		<li>
			<a href="https://www.gannett.com/terms-of-use/" target="_blank">Terms of Use</a>
		</li>
		<li>
			<a href="https://www.gannett.com/privacy-statement/" target="_blank">Privacy Policy</a>
		</li>
		<li>
			<a href="https://www.gannett.com/brands/" target="_blank">Gannett Publications</a>
		</li>
	</ul>
</footer>
				</div>
				<footer id="footer-drawer">
					<div id="drawer-weather" class="visible-xs-block text-center" data-gh-fetch-html-loaded="false" data-gh-fetch-html-url="https://www.echo-pilot.com/section/?template=ajaxWeather" data-gh-fetch-html-dom="#drawer-weather">
					</div>
					<ul class="social list-inline">
						<li>
							<a	href="http://www.facebook.com/pages/Echo-Pilot-Greencastle-Antrims-Hometown-Newspaper/126802110667335""
								target="_blank"
								title="Echo Pilot - Greencastle, PA Facebook">
								<i class="fa fa-fw fa-facebook"></i>
							</a>
						</li>
						<li>
							<a	href="http://www.twitter.com/PatFridgenEP""
								target="_blank"
								title="Echo Pilot - Greencastle, PA Twitter">
								<i class="fa fa-fw fa-twitter"></i>
							</a>
						</li>
						<li>
							<a	href="/section/feed"
								target="_blank"
								title="Echo Pilot - Greencastle, PA RSS Feed">
								<i class="fa fa-fw fa-rss"></i>
							</a>
						</li>
						<li>
							<a	href="https://www.echo-pilot.com/contact"
								title="Contact Echo Pilot - Greencastle, PA">
								<i class="fa fa-fw fa-envelope"></i>
							</a>
						</li>
					</ul>
					<!-- <span id="drawer-copyrightInfo">&copy; 2015 __SITENAME__</span> -->
				</footer>
			</div><!-- /.inner -->
		</nav>
		<div id="drawer-fade-screen"></div>
		<div id="dialog-message" data-gh-object-loaded="false" data-gh-object='{"method":"__gh__webApp.messageCenter.load","data":{"storageKey":"messageCenter"}}' class="slideUp hide">
    <header>
        <h3 class="dialog-title">SUBSCRIBE TODAY</h3>
        <div class="dialog-controls">
            <i id="dialog-minimize" class="fa fa-fw fa-window-minimize"></i>
            <i id="dialog-close" class="fa fa-fw fa-lg fa-times"></i>
        </div>
    </header>
    <div class="inner">
        <div class="dialog-content">
           <p><span>Choose the plan that&rsquo;s right for you. Digital access or digital and print delivery.</span></p>
        </div>
	        <a href="http://echo-pilot.com/subscribenow" class="btn btn-highlight" data-gh-tracker-track-event-object='{"category":"message center pop up","action":"click-action","label":"http://www.echo-pilot.com/apps/pbcs.dll/article?avis=PA&date=20200312&category=ENTERTAINMENTLIFE&lopenr=200319709&Ref=AR"}'>
	            Learn More
	        </a>
    </div>
</div>

				<script type="text/javascript">
		__gh__coreData.pageData.pageType2 = "Article";
		</script>
		<script src="//cdn.gatehousemedia.com/gh-sites/global/ads/ads.js" crossorigin="anonymous"></script>
		<script src="//cdn.gatehousemedia.com/assets/2.0.433/app.min.js" crossorigin="anonymous"></script>
		<script>
window.googletag = window.googletag || {};
window.googletag.cmd = window.googletag.cmd || [];
</script>
<script>
  window.confiant = window.confiant || {};
  window.confiant.enable_integrations = ['gpt'];
  var pbjs = pbjs || {};
  pbjs.que = pbjs.que || [];
</script>
<script async="" src="https://confiant-integrations.global.ssl.fastly.net/JYokDAn2beiT-wdiDnha5IuKJm0/gpt_and_prebid/config.js"></script>
<script>
!function(a9,a,p,s,t,A,g){if(a[a9])return;function q(c,r){a[a9]._Q.push([c,r])}a[a9]={init:function(){q("i",arguments)},fetchBids:function(){q("f",arguments)},setDisplayBids:function(){},_Q:[]};A=p.createElement(s);A.async=!0;A.src=t;g=p.getElementsByTagName(s)[0];g.parentNode.insertBefore( A,g)}("apstag",window,document,"script","//c.amazon-adsystem.com/aax2/apstag.js");</script>
<script async src="https://js-sec.indexww.com/ht/p/183763-221412910371223.js"></script>
<script type="text/javascript">
  window._taboola = window._taboola || [];
  _taboola.push({flush: true});
</script>
		<script>
		function __gh__init() {
		var delay = 100;
			var maxDelay = 45000;
			var __gh__asyncInit = setInterval(function() {
			    if (typeof $ !== 'undefined' && typeof __gh__webApp !== 'undefined') {
			    	try {
						__gh__webApp.init();
						__gh__webApp.articlePage.init();
					} catch (e) {
						console.error('webapp failed to initialize', e);
					}
			        clearInterval(__gh__asyncInit);
			    } else if (delay > maxDelay) {
			    	console.error('webapp init timed out');
			        clearInterval(__gh__asyncInit);
			    }
			    delay *= 2;
			}, delay);
		}
		</script>
		<script>__gh__init();</script>
			<script async src="//cdnjs.cloudflare.com/ajax/libs/twitter-bootstrap/3.3.5/js/bootstrap.min.js?201604-1" crossorigin="anonymous"></script>

		
<!--currenttimestamp: 2020-03-12&nbsp;11:13:55-->
	</body>
</html>
